summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/libcxx_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-08-19 14:20:29 -0700
committerKhem Raj <raj.khem@gmail.com>2019-08-20 10:35:47 -0700
commit3b0ba19a69ae11dc34cd9df184effcbdc1b33bf9 (patch)
tree95be39eaf9ef7cc8550b82c0e0999ccfa23854e2 /recipes-devtools/clang/libcxx_git.bb
parent9418499c3950bbb15dd85286c3a527e8579e4000 (diff)
downloadmeta-clang-3b0ba19a69ae11dc34cd9df184effcbdc1b33bf9.tar.gz
libcxx: Disable llvm libunwind when using gcc as system compiler
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/libcxx_git.bb')
-rw-r--r--recipes-devtools/clang/libcxx_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index 4882513..5e8deb9 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -17,6 +17,7 @@ TARGET_CXXFLAGS_remove_toolchain-clang = "--stdlib=libc++"
17TUNE_CCARGS_remove_toolchain-clang = "--rtlib=compiler-rt --unwindlib=libunwind --stdlib=libc++" 17TUNE_CCARGS_remove_toolchain-clang = "--rtlib=compiler-rt --unwindlib=libunwind --stdlib=libc++"
18 18
19PACKAGECONFIG ??= "unwind" 19PACKAGECONFIG ??= "unwind"
20PACKAGECONFIG_toolchain-gcc = ""
20PACKAGECONFIG_powerpc = "" 21PACKAGECONFIG_powerpc = ""
21PACKAGECONFIG_riscv64 = "" 22PACKAGECONFIG_riscv64 = ""
22PACKAGECONFIG_riscv32 = "" 23PACKAGECONFIG_riscv32 = ""
@@ -89,4 +90,3 @@ RPROVIDES_${PN}-locale += "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libu
89RPROVIDES_${PN}-src += "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libunwind-src', '', d)}" 90RPROVIDES_${PN}-src += "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libunwind-src', '', d)}"
90 91
91BBCLASSEXTEND = "native nativesdk" 92BBCLASSEXTEND = "native nativesdk"
92TOOLCHAIN_forcevariable = "clang"