summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/libcxx_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-08-02 18:14:19 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:00:28 -0700
commit1fbf558d6ff699ae0c8b60ad8313515367e83898 (patch)
tree5bd925faba39793ad7b001689d38b9d89cd4b748 /recipes-devtools/clang/libcxx_git.bb
parent953591e89fba92501cf421adf448aa69caa12e14 (diff)
downloadmeta-clang-1fbf558d6ff699ae0c8b60ad8313515367e83898.tar.gz
recipes: Fix remaining override conversion
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/libcxx_git.bb')
-rw-r--r--recipes-devtools/clang/libcxx_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index 9ee3d34..4ce6814 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -85,7 +85,7 @@ CXXFLAGS:append:armv5 = " -mfpu=vfp2"
85 85
86ALLOW_EMPTY:${PN} = "1" 86ALLOW_EMPTY:${PN} = "1"
87 87
88PROVIDES:append_runtime-llvm = " libunwind" 88PROVIDES:append:runtime-llvm = " libunwind"
89 89
90do_install:append() { 90do_install:append() {
91 if ${@bb.utils.contains("RUNTIME", "llvm", "true", "false", d)} 91 if ${@bb.utils.contains("RUNTIME", "llvm", "true", "false", d)}
@@ -97,8 +97,8 @@ do_install:append() {
97 fi 97 fi
98} 98}
99 99
100PACKAGES:append_runtime-llvm = " libunwind" 100PACKAGES:append:runtime-llvm = " libunwind"
101FILES:libunwind_runtime-llvm = "${libdir}/libunwind.so.*" 101FILES:libunwind:runtime-llvm = "${libdir}/libunwind.so.*"
102 102
103BBCLASSEXTEND = "native nativesdk" 103BBCLASSEXTEND = "native nativesdk"
104TOOLCHAIN:forcevariable = "clang" 104TOOLCHAIN:forcevariable = "clang"