summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/libclc_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-16 19:56:55 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-08 11:37:54 -0700
commitd692c0338fe60cdbb3025dcedbb05ca466335650 (patch)
treefaaeb6870c2923671d229fc8d6ef73367f4b181b /recipes-devtools/clang/libclc_git.bb
parent79dc9a07e919bbcadb137a9d4cb0f857a672d67e (diff)
downloadmeta-clang-d692c0338fe60cdbb3025dcedbb05ca466335650.tar.gz
libclc: Pass -cl-no-stdinc to compiler and assembler
libclc uses clang CLC preprocessor on .ll files, llvm/clang-13 started including clc declarations by default (clang cf3ef15a6ec5e5b45c6c54e8fbe3769255e815ce), thus corrupting any .ll assembly files that are used by libclc. Inclusion of the default declarations can be turned off using a cmdline switch but that remains to be implemented in the libclc build system. manually adding '-cl-no-stdinc' should work as a workaround. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/libclc_git.bb')
-rw-r--r--recipes-devtools/clang/libclc_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-devtools/clang/libclc_git.bb b/recipes-devtools/clang/libclc_git.bb
index 9525b25..4edd4bf 100644
--- a/recipes-devtools/clang/libclc_git.bb
+++ b/recipes-devtools/clang/libclc_git.bb
@@ -19,6 +19,7 @@ EXTRA_OECMAKE += " \
19 -DCMAKE_CROSSCOMPILING_EMULATOR=${WORKDIR}/qemuwrapper \ 19 -DCMAKE_CROSSCOMPILING_EMULATOR=${WORKDIR}/qemuwrapper \
20 -Dclc_comp_in:FILEPATH=${OECMAKE_SOURCEPATH}/cmake/CMakeCLCCompiler.cmake.in \ 20 -Dclc_comp_in:FILEPATH=${OECMAKE_SOURCEPATH}/cmake/CMakeCLCCompiler.cmake.in \
21 -Dll_comp_in:FILEPATH=${OECMAKE_SOURCEPATH}/cmake/CMakeLLAsmCompiler.cmake.in \ 21 -Dll_comp_in:FILEPATH=${OECMAKE_SOURCEPATH}/cmake/CMakeLLAsmCompiler.cmake.in \
22 -DCMAKE_LLAsm_FLAGS=-cl-no-stdinc -DCMAKE_CLC_FLAGS=-cl-no-stdinc \
22 " 23 "
23 24
24do_configure_prepend () { 25do_configure_prepend () {