summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/libclc_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-14 21:05:26 -0800
committerKhem Raj <raj.khem@gmail.com>2021-03-01 11:12:14 -0800
commit826b12ef16e8624657a211e0c5e5ad02c92e1e19 (patch)
tree2eee70333e04d8c708c850f7c7fe37c49a3e8e4d /recipes-devtools/clang/libclc_git.bb
parentaa1ab889bcbb580f33151933d7ed44fd4a93f1bf (diff)
downloadmeta-clang-826b12ef16e8624657a211e0c5e5ad02c92e1e19.tar.gz
libclc: Add dependency on spirv-llvm-translator
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/libclc_git.bb')
-rw-r--r--recipes-devtools/clang/libclc_git.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/recipes-devtools/clang/libclc_git.bb b/recipes-devtools/clang/libclc_git.bb
index 3dd8a7b..9525b25 100644
--- a/recipes-devtools/clang/libclc_git.bb
+++ b/recipes-devtools/clang/libclc_git.bb
@@ -11,9 +11,7 @@ LIC_FILES_CHKSUM = "file://libclc/LICENSE.TXT;md5=7cc795f6cbb2d801d84336b83c8017
11 11
12inherit cmake pkgconfig python3native qemu 12inherit cmake pkgconfig python3native qemu
13 13
14SPIRV_DEP = "${@'spirv-tools spirv-tools-native' if int(d.getVar('MAJOR_VER')) >= 12 else ''}" 14DEPENDS += "qemu-native clang spirv-tools spirv-llvm-translator spirv-llvm-translator-native ncurses"
15
16DEPENDS_append = " qemu-native clang ${SPIRV_DEP}"
17 15
18OECMAKE_SOURCEPATH = "${S}/libclc" 16OECMAKE_SOURCEPATH = "${S}/libclc"
19 17