summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/compiler-rt_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-02-23 13:19:18 -0800
committerKhem Raj <raj.khem@gmail.com>2019-02-23 23:59:49 -0800
commitf6a32267065170803d22e636ecd05c2809a2b5dc (patch)
treee74cef23c68fb8e3dbb0c200a175fefe1cffc4a7 /recipes-devtools/clang/compiler-rt_git.bb
parent4ab185d61afb5b6660e64fb1764015fc35f2c98a (diff)
downloadmeta-clang-f6a32267065170803d22e636ecd05c2809a2b5dc.tar.gz
compiler-rt,libcxx: Add --stdlib=libc++ to compiler flags
- We do not need it with CXX - adding to compiler flag makes sure that libcxx headers are used even when C (clang) compiler is used - Eventually libcxx should provide virtual/${TARGET_PREFIX}compilerlibs add it in comments Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/compiler-rt_git.bb')
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index bc55913..3158380 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -16,9 +16,9 @@ LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=f981c4637a4cd67915ac527b3
16" 16"
17 17
18BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt libcxx" 18BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt libcxx"
19CXX_remove_toolchain-clang = "-stdlib=libc++" 19DEPENDS_append_toolchain-clang_class-target = " virtual/${TARGET_PREFIX}compilerlibs"
20TARGET_CXXFLAGS_remove_toolchain-clang = "-stdlib=libc++" 20TARGET_CXXFLAGS_remove_toolchain-clang = "--stdlib=libc++"
21TUNE_CCARGS_remove_toolchain-clang = "--rtlib=compiler-rt" 21TUNE_CCARGS_remove_toolchain-clang = "--rtlib=compiler-rt --stdlib=libc++"
22TUNE_CCARGS_remove = "-no-integrated-as" 22TUNE_CCARGS_remove = "-no-integrated-as"
23DEPENDS += "ninja-native" 23DEPENDS += "ninja-native"
24DEPENDS_append_class-nativesdk = " clang-native" 24DEPENDS_append_class-nativesdk = " clang-native"