summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/compiler-rt_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-16 09:10:54 -0700
committerKhem Raj <raj.khem@gmail.com>2017-03-16 09:10:54 -0700
commitda9df5ff07941351f14b2d406ffcf61b166d2cb5 (patch)
tree5199e04f23317778bcd8ee4fbfb4120c02005387 /recipes-devtools/clang/compiler-rt_git.bb
parent3c289d9ab1bfda19199e5bcacba48256ac34886c (diff)
downloadmeta-clang-da9df5ff07941351f14b2d406ffcf61b166d2cb5.tar.gz
clang/compiler-rt: Use compiler-rt and libcxx as default runtime for target clang
One can still use -stdlib=libstdc++ and -rtlib=libgcc to use gcc runtime Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/compiler-rt_git.bb')
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 9ceaff9..e8da315 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -56,7 +56,7 @@ do_install_append () {
56} 56}
57 57
58FILES_SOLIBSDEV = "" 58FILES_SOLIBSDEV = ""
59FILES_${PN} += "${libdir}/clang/${BASEPV}/lib/linux/lib*${SOLIBSDEV}" 59FILES_${PN} += "${libdir}/clang/${BASEPV}/lib/linux/lib*${SOLIBSDEV} ${libdir}/clang/${BASEPV}/*.txt"
60FILES_${PN}-staticdev += "${libdir}/clang/${BASEPV}/lib/linux/*.a" 60FILES_${PN}-staticdev += "${libdir}/clang/${BASEPV}/lib/linux/*.a"
61INSANE_SKIP_${PN} = "dev-so" 61INSANE_SKIP_${PN} = "dev-so"
62 62
@@ -69,7 +69,7 @@ INSANE_SKIP_${PN} = "dev-so"
69# " 69# "
70# 70#
71 71
72FILES_${PN}-dev += "${libdir}/clang/${BASEPV}/lib/linux/*.syms ${libdir}/clang/${BASEPV}/lib/linux/*.txt" 72FILES_${PN}-dev += "${libdir}/clang/${BASEPV}/lib/linux/*.syms"
73 73
74BBCLASSEXTEND = "native nativesdk" 74BBCLASSEXTEND = "native nativesdk"
75 75