summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/compiler-rt_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-07-27 01:48:52 -0700
committerKhem Raj <raj.khem@gmail.com>2016-07-27 01:48:52 -0700
commitd6d4f6b18ebb9f315427187154d1e5e2f3678a80 (patch)
tree02305cbdf0cc8bb37d55390f10c4c4830460337b /recipes-devtools/clang/compiler-rt_git.bb
parent79f1d07b76ff1fabb508d9ce232a5e5127d1f3a7 (diff)
downloadmeta-clang-d6d4f6b18ebb9f315427187154d1e5e2f3678a80.tar.gz
compiler-rt: Clang uses arm and armhf to differentiate hard-float/soft-float
Add HF to find out the hf or sf configuration on OE we use arm for TARGET_ARCH in both cases. compiler-rt however expects arm and armhf Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/compiler-rt_git.bb')
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index d175c23..6b67d00 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -32,8 +32,10 @@ inherit cmake pkgconfig pythonnative
32THUMB_TUNE_CCARGS = "" 32THUMB_TUNE_CCARGS = ""
33#TUNE_CCARGS += "-nostdlib" 33#TUNE_CCARGS += "-nostdlib"
34 34
35HF = "${@ bb.utils.contains('TUNE_CCARGS_MFLOAT', 'hard', 'hf', '', d)}"
36HF[vardepvalue] = "${HF}"
35EXTRA_OECMAKE += "-DCOMPILER_RT_STANDALONE_BUILD=ON \ 37EXTRA_OECMAKE += "-DCOMPILER_RT_STANDALONE_BUILD=ON \
36 -DCOMPILER_RT_DEFAULT_TARGET_TRIPLE=${HOST_SYS} \ 38 -DCOMPILER_RT_DEFAULT_TARGET_TRIPLE=${HOST_ARCH}${HF}${HOST_VENDOR}-${HOST_OS} \
37" 39"
38 40
39EXTRA_OECMAKE_append_libc-glibc = " -DCOMPILER_RT_BUILD_SANITIZERS=ON " 41EXTRA_OECMAKE_append_libc-glibc = " -DCOMPILER_RT_BUILD_SANITIZERS=ON "