summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/compiler-rt_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-05-09 21:46:47 +0000
committerKhem Raj <raj.khem@gmail.com>2016-05-09 21:46:47 +0000
commitae695e048867e90fe90ffd93773f73f57db061d1 (patch)
tree12b8e2599395ee76a4c9189e749e4a6d6f4993ea /recipes-devtools/clang/compiler-rt_git.bb
parentc9ac15686fab0d7247128237a8b947c5c03a51b8 (diff)
downloadmeta-clang-ae695e048867e90fe90ffd93773f73f57db061d1.tar.gz
compiler-rt: Fix build when blacklist files are installed
We build with COMPILER_RT_STANDALONE_BUILD=1 and that makes the install locaiton to be /usr and not something clang verison specific in /usr/lib so we have to manually move the bits to proper location after regular install Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/compiler-rt_git.bb')
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 6e13bdd..a9391ed 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -37,11 +37,15 @@ EXTRA_OECMAKE_append_libc-glibc = " -DCOMPILER_RT_BUILD_SANITIZERS=ON "
37EXTRA_OECMAKE_append_libc-musl = " -DCOMPILER_RT_BUILD_SANITIZERS=OFF " 37EXTRA_OECMAKE_append_libc-musl = " -DCOMPILER_RT_BUILD_SANITIZERS=OFF "
38 38
39do_install_append () { 39do_install_append () {
40 mv -f ${D}${libdir}/linux/* ${D}${libdir} 40 for f in `find ${D}${libdir}/linux -maxdepth 1 -type f`
41 do
42 mv $f ${D}${libdir}
43 done
41 rmdir ${D}${libdir}/linux 44 rmdir ${D}${libdir}/linux
42 if [ -z `ls -A ${D}${exec_prefix}` ]; then 45 for f in `find ${D}${exec_prefix} -maxdepth 1 -name '*.txt' -type f`
43 mv -f ${D}${exec_prefix}/*.txt ${D}${libdir} 46 do
44 fi 47 mv $f ${D}${libdir}
48 done
45 rm -rf ${D}${libdir}/libclang_rt.asan*.so 49 rm -rf ${D}${libdir}/libclang_rt.asan*.so
46} 50}
47 51