summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/compiler-rt_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-07-29 23:04:31 -0700
committerKhem Raj <raj.khem@gmail.com>2019-08-12 22:00:22 -0700
commit610a8e1a2ce02b77f905bac261e80b023450b573 (patch)
tree3618fab7398e489267dfee8dd1dc485ba1d1d948 /recipes-devtools/clang/compiler-rt_git.bb
parentc969fa61147845efdc6d3a47c782e2a71de745f9 (diff)
downloadmeta-clang-610a8e1a2ce02b77f905bac261e80b023450b573.tar.gz
clang: Upgrade to 9.x-rcX
dont package six.py, its provided by python3-six package default to lp64d ABI and rv64gc ISA. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/compiler-rt_git.bb')
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 9a15211..ff8d353 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -3,7 +3,6 @@
3 3
4DESCRIPTION = "LLVM based C/C++ compiler Runtime" 4DESCRIPTION = "LLVM based C/C++ compiler Runtime"
5HOMEPAGE = "http://compiler-rt.llvm.org/" 5HOMEPAGE = "http://compiler-rt.llvm.org/"
6LICENSE = "MIT | NCSA"
7SECTION = "base" 6SECTION = "base"
8 7
9require clang.inc 8require clang.inc
@@ -12,8 +11,7 @@ require common-source.inc
12inherit cmake pkgconfig pythonnative 11inherit cmake pkgconfig pythonnative
13 12
14 13
15LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=f981c4637a4cd67915ac527b3ead3a59; \ 14LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=d846d1d65baf322d4c485d6ee54e877a"
16"
17 15
18BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt libcxx" 16BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt libcxx"
19DEPENDS_append_toolchain-clang_class-target = " virtual/${TARGET_PREFIX}compilerlibs" 17DEPENDS_append_toolchain-clang_class-target = " virtual/${TARGET_PREFIX}compilerlibs"
@@ -70,6 +68,7 @@ do_install_append () {
70 install -D -m 0644 $f ${D}${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/`basename $f` 68 install -D -m 0644 $f ${D}${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/`basename $f`
71 rm $f 69 rm $f
72 done 70 done
71 rm -rf ${D}${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux/clang_rt.crt*.o
73} 72}
74 73
75FILES_SOLIBSDEV = "" 74FILES_SOLIBSDEV = ""
@@ -77,7 +76,9 @@ FILES_${PN} += "${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux
77 ${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/*.txt \ 76 ${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/*.txt \
78 ${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/share/*.txt" 77 ${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/share/*.txt"
79FILES_${PN}-staticdev += "${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux/*.a" 78FILES_${PN}-staticdev += "${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux/*.a"
80FILES_${PN}-dev += "${datadir} ${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux/*.syms" 79FILES_${PN}-dev += "${datadir} ${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux/*.syms \
80 ${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux/clang_rt.crt*.o \
81 "
81INSANE_SKIP_${PN} = "dev-so" 82INSANE_SKIP_${PN} = "dev-so"
82 83
83#PROVIDES_append_class-target = "\ 84#PROVIDES_append_class-target = "\