summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/compiler-rt_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-05-12 23:14:17 -0700
committerKhem Raj <raj.khem@gmail.com>2018-05-12 23:46:23 -0700
commit5a316712bd0e24e2e810e90b4d9916a35318e52b (patch)
treec2bede13d69f293197fcd4db028ea4e7e9f97ed7 /recipes-devtools/clang/compiler-rt_git.bb
parent7a61e5a0240b87b9c1c30cc53fabf2084cecd2e3 (diff)
downloadmeta-clang-5a316712bd0e24e2e810e90b4d9916a35318e52b.tar.gz
compiler-rt: Drop a workaround to build for aarch64
This workaround seems to no longer be needed for clang6.0 onwards as a bonus, the regressions for compiling for other arches is also gone since we drop this patch. Fixes issue #57 Fixes issue #52 Use internal assembler This fixes the issue reported here https://reviews.llvm.org/D35696 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/compiler-rt_git.bb')
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index e7e5a55..7a63d99 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -20,7 +20,6 @@ SRC_URI = "\
20 file://0002-Simplify-cross-compilation.-Don-t-use-native-compile.patch \ 20 file://0002-Simplify-cross-compilation.-Don-t-use-native-compile.patch \
21 file://0003-Disable-tsan-on-OE-glibc.patch \ 21 file://0003-Disable-tsan-on-OE-glibc.patch \
22 file://0004-cmake-mips-Do-not-specify-target-with-OE.patch \ 22 file://0004-cmake-mips-Do-not-specify-target-with-OE.patch \
23 file://0005-Pass-march-armv8.1-a-instead-of-mcrc.patch \
24" 23"
25 24
26SRCREV_FORMAT = "compiler-rt" 25SRCREV_FORMAT = "compiler-rt"
@@ -28,6 +27,7 @@ SRCREV_FORMAT = "compiler-rt"
28BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt" 27BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt"
29BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx" 28BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx"
30TARGET_CXXFLAGS_remove_toolchain-clang = " -stdlib=libc++ " 29TARGET_CXXFLAGS_remove_toolchain-clang = " -stdlib=libc++ "
30TUNE_CCARGS_remove = "-no-integrated-as"
31 31
32DEPENDS += "ninja-native" 32DEPENDS += "ninja-native"
33 33