summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/compiler-rt_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-27 10:47:14 -0800
committerKhem Raj <raj.khem@gmail.com>2018-12-27 17:29:06 -0800
commit3d4c48bd0afb67396aacbc444fa7f6698724860e (patch)
treec6baddd7ea8c73f781a9f691585108d228684d30 /recipes-devtools/clang/compiler-rt_git.bb
parent463509e8b983a0e999d01c803a1a999b76d70411 (diff)
downloadmeta-clang-3d4c48bd0afb67396aacbc444fa7f6698724860e.tar.gz
recipes: Rework llvm/clang/compiler-rt/libcxx/lldb recipes
This is an overhaul of clang/llvm project related recipes * switch to using a flat mono repo for all clang/llvm projects * Add llvm-project-source recipe which will prepare source tree in work-shared for all recipes much like kernel and gcc * build lld as part of clang recipes, its much easier and saves build time and hopefully nativesdk version will be built now for free * switch to official git repos at git://github.com/llvm-project * Adjust all recipes to use shared sources Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/compiler-rt_git.bb')
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb24
1 files changed, 7 insertions, 17 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index c458836..0bc5a49 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -7,34 +7,22 @@ LICENSE = "MIT | NCSA"
7SECTION = "base" 7SECTION = "base"
8 8
9require clang.inc 9require clang.inc
10require common-source.inc
10 11
11TOOLCHAIN = "clang" 12inherit cmake pkgconfig pythonnative
12 13
13PV .= "+git${SRCPV}"
14 14
15LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=92bfbe70fc44c6e5efc6403a31180ed7; \ 15LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=92bfbe70fc44c6e5efc6403a31180ed7; \
16"
17SRC_URI = "\
18 ${LLVM_GIT}/compiler-rt.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=compiler-rt \
19 file://0001-support-a-new-embedded-linux-target.patch \
20 file://0002-Simplify-cross-compilation.-Don-t-use-native-compile.patch \
21 file://0003-Disable-tsan-on-OE-glibc.patch \
22 file://0004-cmake-mips-Do-not-specify-target-with-OE.patch \
23" 16"
24 17
25SRCREV_FORMAT = "compiler-rt"
26
27BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt" 18BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt"
28BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx" 19BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx"
29TARGET_CXXFLAGS_remove_toolchain-clang = " -stdlib=libc++ " 20TARGET_CXXFLAGS_remove_toolchain-clang = " -stdlib=libc++ "
30TUNE_CCARGS_remove = "-no-integrated-as" 21TUNE_CCARGS_remove = "-no-integrated-as"
22LDFLAGS_append = " -fuse-ld=lld"
31 23
32DEPENDS += "ninja-native" 24DEPENDS += "ninja-native"
33 25
34S = "${WORKDIR}/git"
35
36inherit cmake pkgconfig pythonnative
37
38THUMB_TUNE_CCARGS = "" 26THUMB_TUNE_CCARGS = ""
39#TUNE_CCARGS += "-nostdlib" 27#TUNE_CCARGS += "-nostdlib"
40 28
@@ -43,7 +31,7 @@ HF[vardepvalue] = "${HF}"
43EXTRA_OECMAKE += "-DCOMPILER_RT_STANDALONE_BUILD=ON \ 31EXTRA_OECMAKE += "-DCOMPILER_RT_STANDALONE_BUILD=ON \
44 -DCOMPILER_RT_DEFAULT_TARGET_TRIPLE=${HOST_ARCH}${HF}${HOST_VENDOR}-${HOST_OS} \ 32 -DCOMPILER_RT_DEFAULT_TARGET_TRIPLE=${HOST_ARCH}${HF}${HOST_VENDOR}-${HOST_OS} \
45 -DCOMPILER_RT_BUILD_XRAY=OFF \ 33 -DCOMPILER_RT_BUILD_XRAY=OFF \
46 -G Ninja \ 34 -G Ninja ${S}/compiler-rt \
47" 35"
48 36
49EXTRA_OECMAKE_append_class-nativesdk = "\ 37EXTRA_OECMAKE_append_class-nativesdk = "\
@@ -101,3 +89,5 @@ BBCLASSEXTEND = "native nativesdk"
101 89
102ALLOW_EMPTY_${PN} = "1" 90ALLOW_EMPTY_${PN} = "1"
103ALLOW_EMPTY_${PN}-dev = "1" 91ALLOW_EMPTY_${PN}-dev = "1"
92
93TOOLCHAIN = "clang"