summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/compiler-rt_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-27 18:04:47 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-28 16:55:57 -0700
commit3ae77709d22d2f608f1984a73386067d4dcdaea0 (patch)
treea70cdc62e74c96f9103cac3ef170f3052ef87e39 /recipes-devtools/clang/compiler-rt_git.bb
parentf281ae2887cad78129266a9e697352b13c5e11da (diff)
downloadmeta-clang-3ae77709d22d2f608f1984a73386067d4dcdaea0.tar.gz
runtime: Automatically add llvm-libunwind based on COMPILER_RT asking for --unwindlib=libunwind
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/compiler-rt_git.bb')
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index d6ce083..c24329c 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -13,11 +13,10 @@ inherit cmake pkgconfig pythonnative
13 13
14LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=d846d1d65baf322d4c485d6ee54e877a" 14LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=d846d1d65baf322d4c485d6ee54e877a"
15 15
16BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt libcxx" 16LIBCPLUSPLUS = ""
17DEPENDS_append_toolchain-clang_class-target = " virtual/${TARGET_PREFIX}compilerlibs" 17COMPILER_RT = ""
18TARGET_CXXFLAGS_remove_toolchain-clang = "--stdlib=libc++"
19TUNE_CCARGS_remove_toolchain-clang = "--rtlib=compiler-rt --unwindlib=libunwind --stdlib=libc++"
20TUNE_CCARGS_remove = "-no-integrated-as" 18TUNE_CCARGS_remove = "-no-integrated-as"
19
21DEPENDS += "ninja-native" 20DEPENDS += "ninja-native"
22DEPENDS_append_class-nativesdk = " clang-native" 21DEPENDS_append_class-nativesdk = " clang-native"
23 22