summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/compiler-rt_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-09 10:21:06 -0800
committerKhem Raj <raj.khem@gmail.com>2017-03-09 10:21:06 -0800
commit2d6f70a7ec88290eab19b23f4d235a190cb0a1e7 (patch)
tree1e9d587e3c37eb869b29bf3b6a0e6ca0c5118fe4 /recipes-devtools/clang/compiler-rt_git.bb
parentdbec400eb55509a54bf86b47f276da68a80bd83f (diff)
downloadmeta-clang-2d6f70a7ec88290eab19b23f4d235a190cb0a1e7.tar.gz
compiler-rt: Fix install locations where clang looks for it
This fixes building with clang using compiler-rt on target clang++ --rtlib compiler-rt --stdlib libc++ -lunwind hello.cpp would compile and run on target Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/compiler-rt_git.bb')
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index bd68a5a..9ceaff9 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -41,22 +41,23 @@ EXTRA_OECMAKE += "-DCOMPILER_RT_STANDALONE_BUILD=ON \
41EXTRA_OECMAKE_append_libc-musl = " -DCOMPILER_RT_BUILD_SANITIZERS=OFF -DCOMPILER_RT_BUILD_XRAY=OFF " 41EXTRA_OECMAKE_append_libc-musl = " -DCOMPILER_RT_BUILD_SANITIZERS=OFF -DCOMPILER_RT_BUILD_XRAY=OFF "
42 42
43do_install_append () { 43do_install_append () {
44 install -d ${D}${libdir}/clang/${BASEPV}/lib/linux
44 if [ -d ${D}${libdir}/linux ]; then 45 if [ -d ${D}${libdir}/linux ]; then
45 for f in `find ${D}${libdir}/linux -maxdepth 1 -type f` 46 for f in `find ${D}${libdir}/linux -maxdepth 1 -type f`
46 do 47 do
47 mv $f ${D}${libdir} 48 mv $f ${D}${libdir}/clang/${BASEPV}/lib/linux
48 done 49 done
49 rmdir ${D}${libdir}/linux 50 rmdir ${D}${libdir}/linux
50 fi 51 fi
51 for f in `find ${D}${exec_prefix} -maxdepth 1 -name '*.txt' -type f` 52 for f in `find ${D}${exec_prefix} -maxdepth 1 -name '*.txt' -type f`
52 do 53 do
53 mv $f ${D}${libdir} 54 mv $f ${D}${libdir}/clang/${BASEPV}
54 done 55 done
55 rm -rf ${D}${libdir}/libclang_rt.asan*.so
56} 56}
57 57
58FILES_SOLIBSDEV = "" 58FILES_SOLIBSDEV = ""
59FILES_${PN} += "${libdir}/lib*${SOLIBSDEV}" 59FILES_${PN} += "${libdir}/clang/${BASEPV}/lib/linux/lib*${SOLIBSDEV}"
60FILES_${PN}-staticdev += "${libdir}/clang/${BASEPV}/lib/linux/*.a"
60INSANE_SKIP_${PN} = "dev-so" 61INSANE_SKIP_${PN} = "dev-so"
61 62
62#PROVIDES_append_class-target = "\ 63#PROVIDES_append_class-target = "\
@@ -68,7 +69,7 @@ INSANE_SKIP_${PN} = "dev-so"
68# " 69# "
69# 70#
70 71
71FILES_${PN}-dev += "${libdir}/*.syms ${libdir}/*.txt" 72FILES_${PN}-dev += "${libdir}/clang/${BASEPV}/lib/linux/*.syms ${libdir}/clang/${BASEPV}/lib/linux/*.txt"
72 73
73BBCLASSEXTEND = "native nativesdk" 74BBCLASSEXTEND = "native nativesdk"
74 75