summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/compiler-rt_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-15 03:45:16 -0700
committerKhem Raj <raj.khem@gmail.com>2017-04-15 03:45:16 -0700
commit0cb6aaa39d22c461c076b145cecf4d7e8dae2c7f (patch)
tree64ecb07062e114a01c33780c62f4b80a9b8204d2 /recipes-devtools/clang/compiler-rt_git.bb
parent12e8a3de5eb13b195332e8b1b7441540b59fe1fb (diff)
downloadmeta-clang-0cb6aaa39d22c461c076b145cecf4d7e8dae2c7f.tar.gz
compiler-rt: Disable xray for now
Fails on some arches e.g. rpi3 /mnt/a/build/tmp-glibc/work/cortexa7hf-neon-vfpv4-oe-linux-gnueabi/compiler-rt/4.0.0+gitAUTOINC+1fdc27db84-r0/git/lib/xray/xray_inmemory_log.cc:88:33: error: unknown type name 'L' std::lock_guard<std::mutex> L(LogMutex); ^ /mnt/a/build/tmp-glibc/work/cortexa7hf-neon-vfpv4-oe-linux-gnueabi/compiler-rt/4.0.0+gitAUTOINC+1fdc27db84-r0/git/lib/xray/xray_inmemory_log.cc:182:26: error: no member named 'mutex' in namespace 'std' std::lock_guard<std::mutex> L(LogMutex); ~~~~~^ /mnt/a/build/tmp-glibc/work/cortexa7hf-neon-vfpv4-oe-linux-gnueabi/compiler-rt/4.0.0+gitAUTOINC+1fdc27db84-r0/git/lib/xray/xray_inmemory_log.cc:182:33: error: unknown type name 'L' std::lock_guard<std::mutex> L(LogMutex); ^ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/compiler-rt_git.bb')
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 4ec440c..0b36bd3 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -38,6 +38,7 @@ HF = "${@ bb.utils.contains('TUNE_CCARGS_MFLOAT', 'hard', 'hf', '', d)}"
38HF[vardepvalue] = "${HF}" 38HF[vardepvalue] = "${HF}"
39EXTRA_OECMAKE += "-DCOMPILER_RT_STANDALONE_BUILD=ON \ 39EXTRA_OECMAKE += "-DCOMPILER_RT_STANDALONE_BUILD=ON \
40 -DCOMPILER_RT_DEFAULT_TARGET_TRIPLE=${HOST_ARCH}${HF}${HOST_VENDOR}-${HOST_OS} \ 40 -DCOMPILER_RT_DEFAULT_TARGET_TRIPLE=${HOST_ARCH}${HF}${HOST_VENDOR}-${HOST_OS} \
41 -DCOMPILER_RT_BUILD_XRAY=OFF \
41" 42"
42 43
43EXTRA_OECMAKE_append_class-nativesdk = "\ 44EXTRA_OECMAKE_append_class-nativesdk = "\