summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-09-27 21:20:49 -0700
committerKhem Raj <raj.khem@gmail.com>2021-09-27 22:58:59 -0700
commit826f7287ffb8ae87bd843ecfe4a21a661bb03294 (patch)
tree1fd87ca73122013f30a3825911610ff35c984715 /recipes-devtools/clang/clang_git.bb
parentd236deda20383e66e303399d98544fbcc66155a9 (diff)
downloadmeta-clang-826f7287ffb8ae87bd843ecfe4a21a661bb03294.tar.gz
nativesdk-clang: Fix build when using RUNTIME = llvm
We can not use nativesdk variants of libcxx and compiler-rt yet when compiling nativesdk-clang because, it will need this compiler to build them, so solve this catch-22, since we do not use the runtime built during compiler builds, use libgcc/libstdc++ to pass cmake tests during configure, this should be fine as it will be not needed for final builds where nativesdk-clang will be used, it can still default to llvm runtime on SDK host Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/clang_git.bb')
-rw-r--r--recipes-devtools/clang/clang_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb
index d0f7c48..fcb9885 100644
--- a/recipes-devtools/clang/clang_git.bb
+++ b/recipes-devtools/clang/clang_git.bb
@@ -305,6 +305,8 @@ SSTATE_SCAN_FILES:remove = "*-config"
305TOOLCHAIN = "clang" 305TOOLCHAIN = "clang"
306TOOLCHAIN:class-native = "gcc" 306TOOLCHAIN:class-native = "gcc"
307TOOLCHAIN:class-nativesdk = "clang" 307TOOLCHAIN:class-nativesdk = "clang"
308COMPILER_RT:class-nativesdk:toolchain-clang:runtime-llvm = "-rtlib=libgcc --unwindlib=libgcc"
309LIBCPLUSPLUS:class-nativesdk:toolchain-clang:runtime-llvm = "-stdlib=libstdc++"
308 310
309SYSROOT_DIRS:append:class-target = " ${nonarch_libdir}" 311SYSROOT_DIRS:append:class-target = " ${nonarch_libdir}"
310 312