summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang_git.bb
diff options
context:
space:
mode:
authorPiotr Tworek <tworaz@tworaz.net>2019-08-13 22:35:50 +0200
committerKhem Raj <raj.khem@gmail.com>2019-08-13 18:14:56 -0700
commit1746d053273024037e3ef227130a6582f191993e (patch)
tree8a4982f3d9dd1c1b4cc5edbdf3e67b8921429ed2 /recipes-devtools/clang/clang_git.bb
parent415aa889d8de12b7eb76a35bb691ecfc3aaa5b20 (diff)
downloadmeta-clang-1746d053273024037e3ef227130a6582f191993e.tar.gz
clang: Inherit python3native.
Without this for some reason lldb configure process manages to mix host system provided python3 interpreter with libpython provided in recipe-sysroot-native. As result the build fails with the following error message: | -- Found PythonInterp: /usr/bin/python3.6 (found version "3.6.5") ... | -- Found PythonLibs: /mnt/storage/build-purple/tmp-musl/work/x86_64-linux/clang-native/9.0.0-r0/recipe-sysroot-native/usr/lib/libpython3.7m.so (found version "3.7.4") | CMake Error at /mnt/storage/build-purple/tmp-musl/work-shared/llvm-project-source-9.0.0-r0/git/lldb/cmake/modules/LLDBConfig.cmake:204 (message): | Found incompatible Python interpreter (3.6.5) and Python libraries (3.7.4) | Call Stack (most recent call first): | /mnt/storage/build-purple/tmp-musl/work-shared/llvm-project-source-9.0.0-r0/git/lldb/CMakeLists.txt:20 (include) Signed-off-by: Piotr Tworek <tworaz@tworaz.net>
Diffstat (limited to 'recipes-devtools/clang/clang_git.bb')
-rw-r--r--recipes-devtools/clang/clang_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb
index 4f4af8f..42695e5 100644
--- a/recipes-devtools/clang/clang_git.bb
+++ b/recipes-devtools/clang/clang_git.bb
@@ -17,7 +17,7 @@ BUILD_RANLIB_class-nativesdk = "llvm-ranlib"
17BUILD_NM_class-nativesdk = "llvm-nm" 17BUILD_NM_class-nativesdk = "llvm-nm"
18LDFLAGS_append_class-nativesdk = " -fuse-ld=gold" 18LDFLAGS_append_class-nativesdk = " -fuse-ld=gold"
19 19
20inherit cmake cmake-native 20inherit cmake cmake-native python3native
21 21
22OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH" 22OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"
23 23