summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-04-05 15:01:22 -0700
committerKhem Raj <raj.khem@gmail.com>2021-04-08 07:59:55 -0700
commit0c29503991afebbf08fc41b12e9b30b0f58a77a4 (patch)
tree26fb85e8439e32a88c1a4a40846d93b7f091c869 /recipes-devtools/clang/clang_git.bb
parent7567dd465828ba95e9658f4b91e87a7d474885fc (diff)
downloadmeta-clang-0c29503991afebbf08fc41b12e9b30b0f58a77a4.tar.gz
clang: Do not use lld for building nativsdk clang
While we can, it does not have the sspace for path dance that yocto does for relocable SDK which means clang components may end up being non-relocatable when SDK is installed in longer paths. So for now pay the price of switching back to binutils linker Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/clang_git.bb')
-rw-r--r--recipes-devtools/clang/clang_git.bb1
1 files changed, 0 insertions, 1 deletions
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb
index b8986be..b0c81f1 100644
--- a/recipes-devtools/clang/clang_git.bb
+++ b/recipes-devtools/clang/clang_git.bb
@@ -15,7 +15,6 @@ BUILD_CXX_class-nativesdk = "clang++"
15BUILD_AR_class-nativesdk = "llvm-ar" 15BUILD_AR_class-nativesdk = "llvm-ar"
16BUILD_RANLIB_class-nativesdk = "llvm-ranlib" 16BUILD_RANLIB_class-nativesdk = "llvm-ranlib"
17BUILD_NM_class-nativesdk = "llvm-nm" 17BUILD_NM_class-nativesdk = "llvm-nm"
18LDFLAGS_append_class-nativesdk = " -fuse-ld=lld"
19 18
20inherit cmake cmake-native pkgconfig python3native 19inherit cmake cmake-native pkgconfig python3native
21 20