summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2021-06-24 14:46:57 +0800
committerKhem Raj <raj.khem@gmail.com>2021-06-28 09:05:45 -0700
commit95c264e9bbb36eb0ea043c2f016ccb1334d5396c (patch)
treeef098c7e7bee0fba2f3be8822cdabfa993dee967 /recipes-devtools/clang/clang
parent4d066667c3cbba3b88d2f8d6c5640f5f793d10b4 (diff)
downloadmeta-clang-95c264e9bbb36eb0ea043c2f016ccb1334d5396c.tar.gz
clang: drop git suffix from version variables
other recipe like intel-graphics-compiler, config failed with below error: [IGC] Could not find the LLVM dylib. Aborting. with a suffix in library name make other recipe cannot found it. Backport a patch from 12.0.0 to fix this. Signed-off-by: Changqing Li <changqing.li@windriver.com>
Diffstat (limited to 'recipes-devtools/clang/clang')
-rw-r--r--recipes-devtools/clang/clang/0036-Drop-the-git-suffix-from-various-version-variables.patch70
1 files changed, 70 insertions, 0 deletions
diff --git a/recipes-devtools/clang/clang/0036-Drop-the-git-suffix-from-various-version-variables.patch b/recipes-devtools/clang/clang/0036-Drop-the-git-suffix-from-various-version-variables.patch
new file mode 100644
index 0000000..81978c0
--- /dev/null
+++ b/recipes-devtools/clang/clang/0036-Drop-the-git-suffix-from-various-version-variables.patch
@@ -0,0 +1,70 @@
1From f25f79545c919543e182f629f7101f4b35faaac6 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Wed, 23 Jun 2021 16:25:06 +0800
4Subject: [PATCH] Drop the 'git' suffix from various version variables
5
6Upstream-Status: Backport [cherry-picked from branch 12.0.0]
7
8Signed-off-by: Changqing Li <changqing.li@windriver.com>
9---
10 libcxx/CMakeLists.txt | 2 +-
11 libcxxabi/CMakeLists.txt | 2 +-
12 libunwind/CMakeLists.txt | 2 +-
13 llvm/CMakeLists.txt | 2 +-
14 4 files changed, 4 insertions(+), 4 deletions(-)
15
16diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
17index 06ee1d74a03e..1ead84c19fcb 100644
18--- a/libcxx/CMakeLists.txt
19+++ b/libcxx/CMakeLists.txt
20@@ -29,7 +29,7 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBCXX_STANDALONE_BUIL
21 project(libcxx CXX C)
22
23 set(PACKAGE_NAME libcxx)
24- set(PACKAGE_VERSION 13.0.0git)
25+ set(PACKAGE_VERSION 13.0.0)
26 set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")
27 set(PACKAGE_BUGREPORT "llvm-bugs@lists.llvm.org")
28
29diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
30index fb656e7db9fb..405bc3ceeaa7 100644
31--- a/libcxxabi/CMakeLists.txt
32+++ b/libcxxabi/CMakeLists.txt
33@@ -28,7 +28,7 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBCXXABI_STANDALONE_B
34 project(libcxxabi CXX C)
35
36 set(PACKAGE_NAME libcxxabi)
37- set(PACKAGE_VERSION 11.0.0git)
38+ set(PACKAGE_VERSION 11.0.0)
39 set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")
40 set(PACKAGE_BUGREPORT "llvm-bugs@lists.llvm.org")
41
42diff --git a/libunwind/CMakeLists.txt b/libunwind/CMakeLists.txt
43index a2c03fd3f8aa..82424253c8da 100644
44--- a/libunwind/CMakeLists.txt
45+++ b/libunwind/CMakeLists.txt
46@@ -24,7 +24,7 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBUNWIND_STANDALONE_B
47 project(libunwind LANGUAGES C CXX ASM)
48
49 set(PACKAGE_NAME libunwind)
50- set(PACKAGE_VERSION 13.0.0git)
51+ set(PACKAGE_VERSION 13.0.0)
52 set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")
53 set(PACKAGE_BUGREPORT "llvm-bugs@lists.llvm.org")
54
55diff --git a/llvm/CMakeLists.txt b/llvm/CMakeLists.txt
56index 135036f509d2..c28bc3f8d19d 100644
57--- a/llvm/CMakeLists.txt
58+++ b/llvm/CMakeLists.txt
59@@ -20,7 +20,7 @@ if(NOT DEFINED LLVM_VERSION_PATCH)
60 set(LLVM_VERSION_PATCH 0)
61 endif()
62 if(NOT DEFINED LLVM_VERSION_SUFFIX)
63- set(LLVM_VERSION_SUFFIX git)
64+ set(LLVM_VERSION_SUFFIX "")
65 endif()
66
67 if (NOT PACKAGE_VERSION)
68--
692.17.1
70