summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0029-lldb-Link-with-libatomic-on-x86.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-06-22 17:15:54 -0700
committerKhem Raj <raj.khem@gmail.com>2023-09-19 19:59:21 -0700
commitd52f203a6bd9e8715cd6fff255e4d2a5a5f78b52 (patch)
tree162c9187e556c848f6dba53e72ffc8e9db01fe4d /recipes-devtools/clang/clang/0029-lldb-Link-with-libatomic-on-x86.patch
parente12fa95bb0193fad9b62cbeafee687507763506c (diff)
downloadmeta-clang-d52f203a6bd9e8715cd6fff255e4d2a5a5f78b52.tar.gz
clang: Update to 17.0.1 release branch
Drop riscv multilib patch it does not work with clang 17.0 Release Notes are below https://releases.llvm.org/17.0.1/docs/ReleaseNotes.html https://releases.llvm.org/17.0.1/tools/clang/docs/ReleaseNotes.html https://releases.llvm.org/17.0.1/tools/lld/docs/ReleaseNotes.html https://releases.llvm.org/17.0.1/tools/clang/tools/extra/docs/ReleaseNotes.html https://releases.llvm.org/17.0.1/projects/libcxx/docs/ReleaseNotes.html Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/clang/0029-lldb-Link-with-libatomic-on-x86.patch')
-rw-r--r--recipes-devtools/clang/clang/0029-lldb-Link-with-libatomic-on-x86.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-devtools/clang/clang/0029-lldb-Link-with-libatomic-on-x86.patch b/recipes-devtools/clang/clang/0029-lldb-Link-with-libatomic-on-x86.patch
index 666e14d..6d71f75 100644
--- a/recipes-devtools/clang/clang/0029-lldb-Link-with-libatomic-on-x86.patch
+++ b/recipes-devtools/clang/clang/0029-lldb-Link-with-libatomic-on-x86.patch
@@ -1,4 +1,4 @@
1From 5a16f3cf25bfa15ddccb72f16d296648d6512ede Mon Sep 17 00:00:00 2001 1From 374f62b718dbb04a88764cdfa747cd42ebf57829 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 8 Feb 2022 01:31:26 -0800 3Date: Tue, 8 Feb 2022 01:31:26 -0800
4Subject: [PATCH] lldb: Link with libatomic on x86 4Subject: [PATCH] lldb: Link with libatomic on x86
@@ -17,7 +17,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
17 1 file changed, 4 insertions(+) 17 1 file changed, 4 insertions(+)
18 18
19diff --git a/lldb/source/Utility/CMakeLists.txt b/lldb/source/Utility/CMakeLists.txt 19diff --git a/lldb/source/Utility/CMakeLists.txt b/lldb/source/Utility/CMakeLists.txt
20index 89acd7cd2eaf..6aa84f9d284d 100644 20index b376ace0ebe3..b9bb39220524 100644
21--- a/lldb/source/Utility/CMakeLists.txt 21--- a/lldb/source/Utility/CMakeLists.txt
22+++ b/lldb/source/Utility/CMakeLists.txt 22+++ b/lldb/source/Utility/CMakeLists.txt
23@@ -19,6 +19,10 @@ if (CMAKE_SYSTEM_NAME MATCHES "Windows") 23@@ -19,6 +19,10 @@ if (CMAKE_SYSTEM_NAME MATCHES "Windows")