summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-31 19:28:25 -0700
committerKhem Raj <raj.khem@gmail.com>2021-11-01 06:20:47 -0700
commitd246141aaf71c739d50e32d0c10e12eecf920e45 (patch)
tree43515b8d72f23a5e7860bc79568040ed36b95c7c /recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch
parenta5373e65e813fa95607d0a01bb34835ca12fdcc6 (diff)
downloadmeta-clang-d246141aaf71c739d50e32d0c10e12eecf920e45.tar.gz
clang: Update to latest on 13.x release
bump minor release to 13.0.1 Drop patch to remove git from PACKAGE_VERSION, this is already eliminated from upstream Following changes are part of this change * 08e3a5ccd952 [IntelJITListener] Fix order in JitListener/multiple.ll * 26e2c97bf14c [openmp] [elf_common] Fix linking against LLVM dylib * eb845520ac3c compiler-rt: Fix arch detection for ppc64le * ec4829efcc94 fixes bug #51926 where dangling comma caused overrun * 73daeb3d507f [CUDA] Make sure <string.h> is included with original __THROW defined. * 3ee9a2b63cfd [Support][mips] Remove unnecessary includes from Memory.inc * 47f53eec6485 [Mips] Add glue between CopyFromReg, CopyToReg and RDHWR nodes for TLS * 914355ee793c [CMake] Re-enable use --gc-sections on OpenBSD * 2ac023cd540a [clang] Omit most AttributedStatements from the CFG * 30c05f43b662 [runtimes] Properly handle the sysroot/triple/gcc-toolchain * a797306b7721 [clang-format] [PR51640] - New AfterEnum brace wrapping changes have cause C# behaviour to change * 0a5ae011cd23 [HIP] Fix test rcom-detect.hip * 1a40203f8e94 workflows: Update lldb workaround to latest version of Mac OS X * 8a93745a7121 Remove "In Progress" text from release notes * 449f3049b507 [GHA] Cancel intermediate builds on PRs * cf15ccdeb6d5 Bump version to 13.0.1 * fd1d8c2f04dd [cte] Release notes for clangd-13 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch')
-rw-r--r--recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch b/recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch
index 1013fa2..0829f18 100644
--- a/recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch
+++ b/recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch
@@ -1,4 +1,4 @@
1From 99f413f6e186984945d2b06887b04719f8b592c5 Mon Sep 17 00:00:00 2001 1From 581275e8e40784c6a3f30e69bb5cc7513fe3b475 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 27 Aug 2017 10:37:49 -0700 3Date: Sun, 27 Aug 2017 10:37:49 -0700
4Subject: [PATCH] libcxxabi: Find libunwind headers when 4Subject: [PATCH] libcxxabi: Find libunwind headers when
@@ -17,10 +17,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
17 1 file changed, 11 insertions(+), 10 deletions(-) 17 1 file changed, 11 insertions(+), 10 deletions(-)
18 18
19diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt 19diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
20index 9fb35860d483..971629d81dbe 100644 20index f3060a5d1f93..bca2178f3203 100644
21--- a/libcxxabi/CMakeLists.txt 21--- a/libcxxabi/CMakeLists.txt
22+++ b/libcxxabi/CMakeLists.txt 22+++ b/libcxxabi/CMakeLists.txt
23@@ -510,14 +510,9 @@ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${LIBCXXABI_C_FLAGS}") 23@@ -511,14 +511,9 @@ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${LIBCXXABI_C_FLAGS}")
24 # Setup Source Code 24 # Setup Source Code
25 #=============================================================================== 25 #===============================================================================
26 26
@@ -36,7 +36,7 @@ index 9fb35860d483..971629d81dbe 100644
36 PATHS ${LIBCXXABI_LIBUNWIND_INCLUDES} 36 PATHS ${LIBCXXABI_LIBUNWIND_INCLUDES}
37 ${LIBCXXABI_LIBUNWIND_PATH}/include 37 ${LIBCXXABI_LIBUNWIND_PATH}/include
38 ${CMAKE_BINARY_DIR}/${LIBCXXABI_LIBUNWIND_INCLUDES} 38 ${CMAKE_BINARY_DIR}/${LIBCXXABI_LIBUNWIND_INCLUDES}
39@@ -528,15 +523,21 @@ if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM) 39@@ -529,15 +524,21 @@ if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
40 NO_CMAKE_FIND_ROOT_PATH 40 NO_CMAKE_FIND_ROOT_PATH
41 ) 41 )
42 42