summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-02-04 09:08:36 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-16 08:24:58 -0800
commit6b79646f85f3293e0fbedf07592a94860d659053 (patch)
tree974c06cc6fb34b680ae9217d77c1c49645fc9393 /recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch
parent03648d617e04ec46c227a52e35f5eff766f79814 (diff)
downloadmeta-clang-6b79646f85f3293e0fbedf07592a94860d659053.tar.gz
clang: Upgrade to upcoming clang14 release branch
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch')
-rw-r--r--recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch64
1 files changed, 0 insertions, 64 deletions
diff --git a/recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch b/recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch
deleted file mode 100644
index 0829f18..0000000
--- a/recipes-devtools/clang/clang/0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch
+++ /dev/null
@@ -1,64 +0,0 @@
1From 581275e8e40784c6a3f30e69bb5cc7513fe3b475 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 27 Aug 2017 10:37:49 -0700
4Subject: [PATCH] libcxxabi: Find libunwind headers when
5 LIBCXXABI_LIBUNWIND_INCLUDES is set
6
7Currently, when LIBCXXABI_LIBUNWIND_INCLUDES is set via CMake arguments
8then it ends up not searching the specified dir and unwind.h is not found
9especially for ARM targets
10
11This patch makes the searching synthesized directories and then set
12LIBCXXABI_LIBUNWIND_INCLUDES if its there in environment
13
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 libcxxabi/CMakeLists.txt | 21 +++++++++++----------
17 1 file changed, 11 insertions(+), 10 deletions(-)
18
19diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
20index f3060a5d1f93..bca2178f3203 100644
21--- a/libcxxabi/CMakeLists.txt
22+++ b/libcxxabi/CMakeLists.txt
23@@ -511,14 +511,9 @@ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${LIBCXXABI_C_FLAGS}")
24 # Setup Source Code
25 #===============================================================================
26
27-set(LIBCXXABI_LIBUNWIND_INCLUDES "${LIBCXXABI_LIBUNWIND_INCLUDES}" CACHE PATH
28- "Specify path to libunwind includes." FORCE)
29-set(LIBCXXABI_LIBUNWIND_PATH "${LIBCXXABI_LIBUNWIND_PATH}" CACHE PATH
30- "Specify path to libunwind source." FORCE)
31-
32 include_directories(include)
33 if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
34- find_path(LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL libunwind.h
35+ find_path(LIBCXXABI_LIBUNWIND_INCLUDES libunwind.h
36 PATHS ${LIBCXXABI_LIBUNWIND_INCLUDES}
37 ${LIBCXXABI_LIBUNWIND_PATH}/include
38 ${CMAKE_BINARY_DIR}/${LIBCXXABI_LIBUNWIND_INCLUDES}
39@@ -529,15 +524,21 @@ if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
40 NO_CMAKE_FIND_ROOT_PATH
41 )
42
43- if (LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL STREQUAL "LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL-NOTFOUND")
44- set(LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL "")
45+ if (LIBCXXABI_LIBUNWIND_INCLUDES STREQUAL "LIBCXXABI_LIBUNWIND_INCLUDES-NOTFOUND")
46+ set(LIBCXXABI_LIBUNWIND_INCLUDES "")
47 endif()
48
49- if (NOT LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL STREQUAL "")
50- include_directories("${LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL}")
51+ if (NOT LIBCXXABI_LIBUNWIND_INCLUDES STREQUAL "")
52+ include_directories("${LIBCXXABI_LIBUNWIND_INCLUDES}")
53 endif()
54 endif()
55
56+set(LIBCXXABI_LIBUNWIND_INCLUDES "${LIBCXXABI_LIBUNWIND_INCLUDES}" CACHE PATH
57+ "Specify path to libunwind includes." FORCE)
58+set(LIBCXXABI_LIBUNWIND_PATH "${LIBCXXABI_LIBUNWIND_PATH}" CACHE PATH
59+ "Specify path to libunwind source." FORCE)
60+
61+
62 # Add source code. This also contains all of the logic for deciding linker flags
63 # soname, etc...
64 add_subdirectory(src)