summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang-cross_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-27 10:47:14 -0800
committerKhem Raj <raj.khem@gmail.com>2018-12-27 17:29:06 -0800
commit3d4c48bd0afb67396aacbc444fa7f6698724860e (patch)
treec6baddd7ea8c73f781a9f691585108d228684d30 /recipes-devtools/clang/clang-cross_git.bb
parent463509e8b983a0e999d01c803a1a999b76d70411 (diff)
downloadmeta-clang-3d4c48bd0afb67396aacbc444fa7f6698724860e.tar.gz
recipes: Rework llvm/clang/compiler-rt/libcxx/lldb recipes
This is an overhaul of clang/llvm project related recipes * switch to using a flat mono repo for all clang/llvm projects * Add llvm-project-source recipe which will prepare source tree in work-shared for all recipes much like kernel and gcc * build lld as part of clang recipes, its much easier and saves build time and hopefully nativesdk version will be built now for free * switch to official git repos at git://github.com/llvm-project * Adjust all recipes to use shared sources Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/clang-cross_git.bb')
-rw-r--r--recipes-devtools/clang/clang-cross_git.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/recipes-devtools/clang/clang-cross_git.bb b/recipes-devtools/clang/clang-cross_git.bb
index 083acb5..618aa5d 100644
--- a/recipes-devtools/clang/clang-cross_git.bb
+++ b/recipes-devtools/clang/clang-cross_git.bb
@@ -10,11 +10,10 @@ SECTION = "devel"
10PN = "clang-cross-${TARGET_ARCH}" 10PN = "clang-cross-${TARGET_ARCH}"
11 11
12require clang.inc 12require clang.inc
13require common-source.inc
13inherit cross 14inherit cross
14DEPENDS += "clang-native binutils-cross-${TARGET_ARCH}" 15DEPENDS += "clang-native binutils-cross-${TARGET_ARCH}"
15 16
16S = "${WORKDIR}"
17
18do_install() { 17do_install() {
19 install -d ${D}${bindir} 18 install -d ${D}${bindir}
20 ln -sf ../clang ${D}${bindir}/${TARGET_PREFIX}clang 19 ln -sf ../clang ${D}${bindir}/${TARGET_PREFIX}clang