summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/bpftrace/bpftrace_0.9.4.bb
diff options
context:
space:
mode:
authorLeo Yan <leo.yan@linaro.org>2020-02-23 05:26:32 +0000
committerKhem Raj <raj.khem@gmail.com>2020-02-23 22:34:40 -0800
commit68531e8a272c746680def7543119fbfd84d68361 (patch)
tree1a74abef4ac97113efa65633e5046a15f0a9cf46 /recipes-devtools/bpftrace/bpftrace_0.9.4.bb
parent7210e0b0de329cb744afe111153f2cd94a6a6196 (diff)
downloadmeta-clang-68531e8a272c746680def7543119fbfd84d68361.tar.gz
bpftrace: Add build recipe
bpftrace is a high-level tracing language for eBPF, its language is inspired by awk and C, and predecessor tracers such as DTrace and SystemTap. bpftrace was created by Alastair Robertson. bpftrace language supports the usages for one-liner and script, it's very powerful for tracing and profiling. bpftrace internal mechanism depends on BCC and LLVM/Clang, so the building dependency has contains these modules. Add recipe for bpftrace version 0.9.4. This patch also contains a patch to change cmake file so can look for libraries and headers which are installed in target sysroot-recipe path for cross compilation. Signed-off-by: Sumit Garg <sumit.garg@linaro.org> Co-developed-by: Leo Yan <leo.yan@linaro.org>
Diffstat (limited to 'recipes-devtools/bpftrace/bpftrace_0.9.4.bb')
-rw-r--r--recipes-devtools/bpftrace/bpftrace_0.9.4.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-devtools/bpftrace/bpftrace_0.9.4.bb b/recipes-devtools/bpftrace/bpftrace_0.9.4.bb
new file mode 100644
index 0000000..2afb430
--- /dev/null
+++ b/recipes-devtools/bpftrace/bpftrace_0.9.4.bb
@@ -0,0 +1,36 @@
1SUMMARY = "bpftrace"
2HOMEPAGE = "https://github.com/iovisor/bpftrace"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS += "bison-native \
7 ninja-native \
8 elfutils-native \
9 flex-native \
10 gtest-native \
11 git-native \
12 ${MLPREFIX}elfutils \
13 ${MLPREFIX}binutils \
14 ${MLPREFIX}flex \
15 clang \
16 bcc \
17 "
18
19RDEPENDS_${PN} += "bash python3"
20
21SRC_URI = "git://github.com/iovisor/bpftrace \
22 file://0001-Allow-to-build-with-OE-llvm-clang-cross-compiled-pac.patch \
23 "
24SRCREV = "85f9eea624c83443816e37654d0c1c93366a2e66"
25
26S = "${WORKDIR}/git"
27
28inherit cmake
29
30OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"
31
32EXTRA_OECMAKE = " \
33 -DCMAKE_BUILD_TYPE=Release \
34"
35
36FILES_${PN} += "${prefix}/man/*"