summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/bcc/bcc_0.13.0.bb
diff options
context:
space:
mode:
authorOvidiu Panait <ovidiu.panait@windriver.com>2020-03-03 17:14:52 +0200
committerKhem Raj <raj.khem@gmail.com>2020-03-04 19:31:09 -0800
commit8d8da26055e9f6b61f5a61da7d191c2b54944b33 (patch)
treea356e0335952b37b16436dd7fd52e8a472924b46 /recipes-devtools/bcc/bcc_0.13.0.bb
parent7deec9d9e294eb976319833793dacdafc0fe45ed (diff)
downloadmeta-clang-8d8da26055e9f6b61f5a61da7d191c2b54944b33.tar.gz
bcc: Replace python3 patch with do_install_append sed
Use sed to replace all occurences of /usr/bin/env python with the python3 variant instead of maintaining a patch that does this. Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
Diffstat (limited to 'recipes-devtools/bcc/bcc_0.13.0.bb')
-rw-r--r--recipes-devtools/bcc/bcc_0.13.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-devtools/bcc/bcc_0.13.0.bb b/recipes-devtools/bcc/bcc_0.13.0.bb
index 2a346c1..6c92b17 100644
--- a/recipes-devtools/bcc/bcc_0.13.0.bb
+++ b/recipes-devtools/bcc/bcc_0.13.0.bb
@@ -18,7 +18,6 @@ RDEPENDS_${PN} += "bash python3 python3-core"
18 18
19SRC_URI = "git://github.com/iovisor/bcc \ 19SRC_URI = "git://github.com/iovisor/bcc \
20 file://0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch \ 20 file://0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch \
21 file://0001-BCC-Use-python-3.patch \
22 " 21 "
23SRCREV = "942227484d3207f6a42103674001ef01fb5335a0" 22SRCREV = "942227484d3207f6a42103674001ef01fb5335a0"
24 23
@@ -35,6 +34,11 @@ EXTRA_OECMAKE = " \
35 -DPYTHON_CMD=python3 \ 34 -DPYTHON_CMD=python3 \
36" 35"
37 36
37do_install_append() {
38 sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \
39 -i $(find ${D}${datadir}/${PN} -type f)
40}
41
38FILES_${PN} += "${libdir}/python*/dist-packages" 42FILES_${PN} += "${libdir}/python*/dist-packages"
39 43
40COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux" 44COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"