summaryrefslogtreecommitdiffstats
path: root/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-12-02 14:32:42 +0000
committerKhem Raj <raj.khem@gmail.com>2019-12-02 08:55:03 -0800
commitfabbdc8b851009163d33c8b64d0251a8cc88e71e (patch)
tree0dbf99a81fd3e87c5b21ddb4d92e863343dbd43f /recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
parent96336131295c5592a70b21e5865103f237d1574a (diff)
downloadmeta-clang-fabbdc8b851009163d33c8b64d0251a8cc88e71e.tar.gz
packagegroup: be lenient about CLANGSDK setting
As CLANGSDK defaults to '1', users who have not read the README may think that setting it to '0' would disable adding Clang to the SDK. Little do they know that you need to *unset* the value for this to work (as bool('0') -> True). Change the logic to use bb.utils.contains(), so that '0' is not true. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend')
-rw-r--r--recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend b/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
index 3472eb3..0c8ae6c 100644
--- a/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
+++ b/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
@@ -1 +1 @@
RDEPENDS_${PN} += "${@'nativesdk-clang' if '${CLANGSDK}' else ''}" RDEPENDS_${PN} += "${@bb.utils.contains('CLANGSDK', '1', 'nativesdk-clang', '', d)}"