summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorEtienne Cordonnier <ecordonnier@snap.com>2023-03-02 11:46:33 +0100
committerKhem Raj <raj.khem@gmail.com>2023-03-06 10:21:29 -0800
commitbb3c933575b442297ac7292e8e9926d777627596 (patch)
treee6913d59d0a8dae817f2083e432d2d1078b30f48 /dynamic-layers
parenta8cf1b5b632c41c7885c76fb2a92ccebc327a901 (diff)
downloadmeta-clang-bb3c933575b442297ac7292e8e9926d777627596.tar.gz
android-tools: correctly pass DEB_HOST_ARCH to libbacktrace
- The code was producing the error "tool: command not found" and the else branch was always executed, even for libbacktrace. - There is no variable "deb_host_arch" defined in rules.yocto, so it's not clear what the first line of the patch with DEB_HOST_ARCH=${deb_host_arch} was supposed to do. "${deb_host_arch}" is always undefined in this context. Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/selinux/android-tools/android-tools/libbacktrace_mk_change_out_dir.patch6
-rw-r--r--dynamic-layers/selinux/android-tools/android-tools_10.0.0.r36.bb2
2 files changed, 3 insertions, 5 deletions
diff --git a/dynamic-layers/selinux/android-tools/android-tools/libbacktrace_mk_change_out_dir.patch b/dynamic-layers/selinux/android-tools/android-tools/libbacktrace_mk_change_out_dir.patch
index 464b63d..8115170 100644
--- a/dynamic-layers/selinux/android-tools/android-tools/libbacktrace_mk_change_out_dir.patch
+++ b/dynamic-layers/selinux/android-tools/android-tools/libbacktrace_mk_change_out_dir.patch
@@ -19,12 +19,10 @@ Upstream-Status: Pending
19 19
20--- git/system/core/debian/libbacktrace.mk 2021-05-21 23:51:55.022408433 +0000 20--- git/system/core/debian/libbacktrace.mk 2021-05-21 23:51:55.022408433 +0000
21+++ git/system/core/debian/libbacktrace.mk 2021-05-21 23:53:07.487543521 +0000 21+++ git/system/core/debian/libbacktrace.mk 2021-05-21 23:53:07.487543521 +0000
22@@ -1,5 +1,6 @@ 22@@ -1,5 +1,5 @@
23- 23
24-include /usr/share/dpkg/architecture.mk 24-include /usr/share/dpkg/architecture.mk
25+include ../../rules_yocto.mk 25+include ../../rules_yocto.mk
26+#pass architecture specific info to makefile
27+DEB_HOST_ARCH=${deb_host_arch}
28 26
29 NAME = libbacktrace 27 NAME = libbacktrace
30 28
diff --git a/dynamic-layers/selinux/android-tools/android-tools_10.0.0.r36.bb b/dynamic-layers/selinux/android-tools/android-tools_10.0.0.r36.bb
index 7fa7e30..db51f69 100644
--- a/dynamic-layers/selinux/android-tools/android-tools_10.0.0.r36.bb
+++ b/dynamic-layers/selinux/android-tools/android-tools_10.0.0.r36.bb
@@ -145,7 +145,7 @@ do_compile() {
145 done 145 done
146 146
147 for tool in ${TOOLS_TO_BUILD}; do 147 for tool in ${TOOLS_TO_BUILD}; do
148 if tool == "libbacktrace"; then 148 if [ "$tool" == "libbacktrace" ]; then
149 oe_runmake -f ${S}/system/core/debian/${tool}.mk -C ${S}/system/core DEB_HOST_ARCH=${deb_host_arch} 149 oe_runmake -f ${S}/system/core/debian/${tool}.mk -C ${S}/system/core DEB_HOST_ARCH=${deb_host_arch}
150 else 150 else
151 oe_runmake -f ${S}/system/core/debian/${tool}.mk -C ${S}/system/core 151 oe_runmake -f ${S}/system/core/debian/${tool}.mk -C ${S}/system/core