summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei.gherzan@huawei.com>2021-12-09 14:33:07 +0100
committerKhem Raj <raj.khem@gmail.com>2021-12-09 08:46:29 -0800
commit7294d0ec96f7a8396632b7153c8a76c58b142412 (patch)
treea70f1e9a3beda92ffef55eb866579a371844b1f6 /dynamic-layers
parentf9a2051ea638d24e7339a0878c64acdeb1525aca (diff)
downloadmeta-clang-7294d0ec96f7a8396632b7153c8a76c58b142412.tar.gz
android-tools: Fix syntax overrides
Signed-off-by: Andrei Gherzan <andrei.gherzan@huawei.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/selinux/android-tools/android-tools_10.0.0.r36.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/dynamic-layers/selinux/android-tools/android-tools_10.0.0.r36.bb b/dynamic-layers/selinux/android-tools/android-tools_10.0.0.r36.bb
index 916e801..93637a7 100644
--- a/dynamic-layers/selinux/android-tools/android-tools_10.0.0.r36.bb
+++ b/dynamic-layers/selinux/android-tools/android-tools_10.0.0.r36.bb
@@ -68,12 +68,12 @@ do_unpack_and_patch_debian() {
68addtask unpack_and_patch_debian after do_unpack before do_patch 68addtask unpack_and_patch_debian after do_unpack before do_patch
69 69
70# http://errors.yoctoproject.org/Errors/Details/1debian881/ 70# http://errors.yoctoproject.org/Errors/Details/1debian881/
71ARM_INSTRUCTION_SET_armv4 = "arm" 71ARM_INSTRUCTION_SET:armv4 = "arm"
72ARM_INSTRUCTION_SET_armv5 = "arm" 72ARM_INSTRUCTION_SET:armv5 = "arm"
73 73
74COMPATIBLE_HOST_powerpc = "(null)" 74COMPATIBLE_HOST:powerpc = "(null)"
75COMPATIBLE_HOST_powerpc64 = "(null)" 75COMPATIBLE_HOST:powerpc64 = "(null)"
76COMPATIBLE_HOST_powerpc64le = "(null)" 76COMPATIBLE_HOST:powerpc64le = "(null)"
77 77
78inherit systemd clang 78inherit systemd clang
79 79
@@ -85,15 +85,15 @@ DEPENDS += "\
85SYSTEMD_SERVICE:${PN} = "android-tools-adbd.service" 85SYSTEMD_SERVICE:${PN} = "android-tools-adbd.service"
86 86
87# Find libbsd headers during native builds 87# Find libbsd headers during native builds
88CC:append_class-native = " -I${STAGING_INCDIR}" 88CC:append:class-native = " -I${STAGING_INCDIR}"
89CC:append_class-nativesdk = " -I${STAGING_INCDIR}" 89CC:append:class-nativesdk = " -I${STAGING_INCDIR}"
90 90
91PREREQUISITE_core = "libbase libsparse liblog libcutils" 91PREREQUISITE_core = "libbase libsparse liblog libcutils"
92TOOLS_TO_BUILD = "libcrypto_utils libadb libziparchive fastboot adb img2simg simg2img libbacktrace" 92TOOLS_TO_BUILD = "libcrypto_utils libadb libziparchive fastboot adb img2simg simg2img libbacktrace"
93 93
94# Adb needs sys/capability.h, which is not available for native* 94# Adb needs sys/capability.h, which is not available for native*
95TOOLS_class-native = "boringssl fastboot ext4_utils mkbootimg" 95TOOLS:class-native = "boringssl fastboot ext4_utils mkbootimg"
96TOOLS_class-nativesdk = "boringssl fastboot ext4_utils mkbootimg" 96TOOLS:class-nativesdk = "boringssl fastboot ext4_utils mkbootimg"
97 97
98do_compile() { 98do_compile() {
99 99
@@ -188,7 +188,7 @@ do_install() {
188 188
189PACKAGES += "${PN}-fstools" 189PACKAGES += "${PN}-fstools"
190 190
191RDEPENDS_${BPN} = "${BPN}-conf p7zip" 191RDEPENDS:${BPN} = "${BPN}-conf p7zip"
192 192
193FILES:${PN}-fstools = "\ 193FILES:${PN}-fstools = "\
194 ${bindir}/ext2simg \ 194 ${bindir}/ext2simg \