summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorDaniel Thompson <daniel@redfelineninja.org.uk>2022-05-19 09:37:18 +0000
committerKhem Raj <raj.khem@gmail.com>2022-05-27 11:54:02 -0700
commit64362c7a1c54ad7f1476fac9f58036478178a577 (patch)
treead305218a36af8766cc6ffa1f3f53eb44baeb08c /dynamic-layers
parent229e28a6a061cb78d9f31c253ee8e741a093ab8d (diff)
downloadmeta-clang-64362c7a1c54ad7f1476fac9f58036478178a577.tar.gz
bcc: De-vendor libbpf
Currently bcc builds against a vendored copy of libbpf. This causes problems for bpftrace which is built against bcc and the system libbpf. The resulting version skew between the vendored and system versions of libbpf resulting in a SEGV whenever bpftrace is used. Although --help and -l (list probe points) work OK that is because they do not actually use BPF! Anything that does use BPF will crash immediately, including bpftrace --info and simple one-liners such as: ~# bpftrace -e 't:raw_syscalls:sys_exit { printf("%s", comm); }' Attaching 1 probe... Segmentation fault Note that this issue is very closely related to similar problems compiling bpftrace against mixed headers from the two libbpf versions. Fixes: https://github.com/iovisor/bpftrace/issues/2173 Fixes: bb3e56b06f9d ("bpftrace: Fix build with new libbpf") Signed-off-by: Daniel Thompson <daniel.thompson@linaro.org>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
index b5e3fe3..2da1fc4 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
@@ -11,6 +11,7 @@ DEPENDS += "bison-native \
11 elfutils \ 11 elfutils \
12 ${LUAJIT} \ 12 ${LUAJIT} \
13 clang \ 13 clang \
14 libbpf \
14 " 15 "
15 16
16LUAJIT ?= "luajit" 17LUAJIT ?= "luajit"
@@ -40,6 +41,7 @@ PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF,"
40PACKAGECONFIG[examples] = "-DENABLE_EXAMPLES=ON,-DENABLE_EXAMPLES=OFF," 41PACKAGECONFIG[examples] = "-DENABLE_EXAMPLES=ON,-DENABLE_EXAMPLES=OFF,"
41 42
42EXTRA_OECMAKE = " \ 43EXTRA_OECMAKE = " \
44 -DCMAKE_USE_LIBBPF_PACKAGE=ON \
43 -DENABLE_LLVM_SHARED=ON \ 45 -DENABLE_LLVM_SHARED=ON \
44 -DENABLE_CLANG_JIT=ON \ 46 -DENABLE_CLANG_JIT=ON \
45 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \ 47 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \