summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorSigned-off-by: Martin Jansa <Martin.Jansa@gmail.com>2021-08-02 09:45:55 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:00:28 -0700
commit17737cc4ecd3aea2c978bf83e283bcb08d097487 (patch)
treea4386a37907d9110572105af80ebe5a1c5bf3819 /dynamic-layers
parent527f628b7d9bbfe8d3fbe743e876d30c4545a71a (diff)
downloadmeta-clang-17737cc4ecd3aea2c978bf83e283bcb08d097487.tar.gz
meta-clang: Convert to new override syntax
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/networking-layer/recipes-connectivity/samba/samba_4.%.bbappend4
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb14
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.11.4.bb4
-rw-r--r--dynamic-layers/openembedded-layer/recipes-kernel/kernel-selftest/kernel-selftest.bbappend6
4 files changed, 14 insertions, 14 deletions
diff --git a/dynamic-layers/networking-layer/recipes-connectivity/samba/samba_4.%.bbappend b/dynamic-layers/networking-layer/recipes-connectivity/samba/samba_4.%.bbappend
index dd3c5f9..543f32c 100644
--- a/dynamic-layers/networking-layer/recipes-connectivity/samba/samba_4.%.bbappend
+++ b/dynamic-layers/networking-layer/recipes-connectivity/samba/samba_4.%.bbappend
@@ -1,3 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
2 2
3SRC_URI_append = " file://fix_duplicate_pdb_search_init.patch " 3SRC_URI:append = " file://fix_duplicate_pdb_search_init.patch "
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb
index 325a6ee..43e828b 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb
@@ -13,10 +13,10 @@ DEPENDS += "bison-native \
13 " 13 "
14 14
15LUAJIT ?= "luajit" 15LUAJIT ?= "luajit"
16LUAJIT_powerpc64le = "" 16LUAJIT:powerpc64le = ""
17LUAJIT_powerpc64 = "" 17LUAJIT:powerpc64 = ""
18 18
19RDEPENDS_${PN} += "bash python3 python3-core python3-setuptools xz" 19RDEPENDS:${PN} += "bash python3 python3-core python3-setuptools xz"
20 20
21SRC_URI = "gitsm://github.com/iovisor/bcc \ 21SRC_URI = "gitsm://github.com/iovisor/bcc \
22 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \ 22 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \
@@ -32,7 +32,7 @@ PV .= "+git${SRCPV}"
32S = "${WORKDIR}/git" 32S = "${WORKDIR}/git"
33 33
34PACKAGECONFIG ??= "examples" 34PACKAGECONFIG ??= "examples"
35PACKAGECONFIG_remove_libc-musl = "examples" 35PACKAGECONFIG:remove:libc-musl = "examples"
36 36
37PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF," 37PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF,"
38PACKAGECONFIG[examples] = "-DENABLE_EXAMPLES=ON,-DENABLE_EXAMPLES=OFF," 38PACKAGECONFIG[examples] = "-DENABLE_EXAMPLES=ON,-DENABLE_EXAMPLES=OFF,"
@@ -45,12 +45,12 @@ EXTRA_OECMAKE = " \
45 -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \ 45 -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \
46" 46"
47 47
48do_install_append() { 48do_install:append() {
49 sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \ 49 sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \
50 -i $(find ${D}${datadir}/${PN} -type f) 50 -i $(find ${D}${datadir}/${PN} -type f)
51} 51}
52 52
53FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}" 53FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
54FILES_${PN}-doc += "${datadir}/${PN}/man" 54FILES:${PN}-doc += "${datadir}/${PN}/man"
55 55
56COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux" 56COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.11.4.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.11.4.bb
index d6ab0ce..9f67d94 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.11.4.bb
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.11.4.bb
@@ -11,7 +11,7 @@ DEPENDS += "bison-native \
11 " 11 "
12 12
13PV .= "+git${SRCREV}" 13PV .= "+git${SRCREV}"
14RDEPENDS_${PN} += "bash python3 xz" 14RDEPENDS:${PN} += "bash python3 xz"
15 15
16SRC_URI = "git://github.com/iovisor/bpftrace;branch=master \ 16SRC_URI = "git://github.com/iovisor/bpftrace;branch=master \
17 file://0001-bpforc.h-Include-optional-header.patch \ 17 file://0001-bpforc.h-Include-optional-header.patch \
@@ -29,4 +29,4 @@ EXTRA_OECMAKE = " \
29" 29"
30 30
31COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux" 31COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"
32COMPATIBLE_HOST_libc-musl = "null" 32COMPATIBLE_HOST:libc-musl = "null"
diff --git a/dynamic-layers/openembedded-layer/recipes-kernel/kernel-selftest/kernel-selftest.bbappend b/dynamic-layers/openembedded-layer/recipes-kernel/kernel-selftest/kernel-selftest.bbappend
index a1d4585..580d98b 100644
--- a/dynamic-layers/openembedded-layer/recipes-kernel/kernel-selftest/kernel-selftest.bbappend
+++ b/dynamic-layers/openembedded-layer/recipes-kernel/kernel-selftest/kernel-selftest.bbappend
@@ -1,4 +1,4 @@
1DEPENDS_append = " clang-native" 1DEPENDS:append = " clang-native"
2DEPENDS_remove = "llvm-native" 2DEPENDS:remove = "llvm-native"
3 3
4EXCLUDE_FROM_WORLD_forcevariable = "" 4EXCLUDE_FROM_WORLD:forcevariable = ""