summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-08-05 08:02:09 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-06 19:54:32 -0700
commit06d032fd13a0ab3c83305abdafad45b8ef006129 (patch)
tree3d272f56a2d2f28a97ab4b5366fecc57ad5f7c4f /dynamic-layers
parente4978cc3ef008c69a49295dc8bc997b8291f6b11 (diff)
downloadmeta-clang-06d032fd13a0ab3c83305abdafad45b8ef006129.tar.gz
bpftrace: Upgrade to 0.13.0
Drop already upstreamed patch Fix build with clang 13 Add missing dependencies on systemtap and libcereal Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-bpforc.h-Include-optional-header.patch31
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-support-clang-upto-version-13.patch27
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.13.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.11.4.bb)8
3 files changed, 33 insertions, 33 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-bpforc.h-Include-optional-header.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-bpforc.h-Include-optional-header.patch
deleted file mode 100644
index c666bfe..0000000
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-bpforc.h-Include-optional-header.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From ec41ce71f8cd318ab3ca4ce727e7398289b5d7cf Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 30 Mar 2021 17:25:10 -0700
4Subject: [PATCH] bpforc.h: Include <optional> header
5
6This is required since this header had std::optional<std::tuple<uint8_t *, uintptr_t>>
7
8Fixes buiild errors with clang-12 with gcc11-runtime
9
10Upstream-Status: Submitted [https://github.com/iovisor/bpftrace/pull/1762]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/bpforc.h | 2 ++
14 1 file changed, 2 insertions(+)
15
16diff --git a/src/bpforc.h b/src/bpforc.h
17index da6345be..5634c544 100644
18--- a/src/bpforc.h
19+++ b/src/bpforc.h
20@@ -22,6 +22,8 @@
21 #include <llvm/ExecutionEngine/Orc/JITTargetMachineBuilder.h>
22 #endif
23
24+#include <optional>
25+
26 namespace bpftrace {
27
28 const std::string LLVMTargetTriple = "bpf-pc-linux";
29--
302.31.1
31
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-support-clang-upto-version-13.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-support-clang-upto-version-13.patch
new file mode 100644
index 0000000..2272635
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-support-clang-upto-version-13.patch
@@ -0,0 +1,27 @@
1From 4cffb745dabde63f6f9c67a95265f5fc670dc1d7 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 5 Aug 2021 22:15:27 -0700
4Subject: [PATCH] support clang upto version 13
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 CMakeLists.txt | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/CMakeLists.txt b/CMakeLists.txt
13index 86daa195..73744207 100644
14--- a/CMakeLists.txt
15+++ b/CMakeLists.txt
16@@ -162,7 +162,7 @@ else()
17 find_package(LLVM REQUIRED)
18 endif()
19
20- if((${LLVM_VERSION_MAJOR} VERSION_LESS 6) OR (${LLVM_VERSION_MAJOR} VERSION_GREATER 12))
21+ if((${LLVM_VERSION_MAJOR} VERSION_LESS 6) OR (${LLVM_VERSION_MAJOR} VERSION_GREATER 13))
22 message(SEND_ERROR "Unsupported LLVM version found: ${LLVM_INCLUDE_DIRS}")
23 message(SEND_ERROR "Specify an LLVM major version using LLVM_REQUESTED_VERSION=<major version>")
24 endif()
25--
262.32.0
27
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.11.4.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.13.0.bb
index 9f67d94..83e4722 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.11.4.bb
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.13.0.bb
@@ -8,15 +8,17 @@ DEPENDS += "bison-native \
8 gzip-native \ 8 gzip-native \
9 elfutils \ 9 elfutils \
10 bcc \ 10 bcc \
11 systemtap \
12 libcereal \
11 " 13 "
12 14
13PV .= "+git${SRCREV}" 15PV .= "+git${SRCREV}"
14RDEPENDS:${PN} += "bash python3 xz" 16RDEPENDS:${PN} += "bash python3 xz"
15 17
16SRC_URI = "git://github.com/iovisor/bpftrace;branch=master \ 18SRC_URI = "git://github.com/iovisor/bpftrace;branch=master \
17 file://0001-bpforc.h-Include-optional-header.patch \ 19 file://0001-support-clang-upto-version-13.patch \
18 " 20 "
19SRCREV = "6bfa61f505b6b4215328f90762776edd8a22fdb7" 21SRCREV = "18aa073ee86260878bc76227a5023171f6c29200"
20 22
21S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
22 24
@@ -25,7 +27,9 @@ inherit cmake
25EXTRA_OECMAKE = " \ 27EXTRA_OECMAKE = " \
26 -DCMAKE_ENABLE_EXPORTS=1 \ 28 -DCMAKE_ENABLE_EXPORTS=1 \
27 -DCMAKE_BUILD_TYPE=Release \ 29 -DCMAKE_BUILD_TYPE=Release \
30 -DLLVM_REQUESTED_VERSION=13 \
28 -DBUILD_TESTING=OFF \ 31 -DBUILD_TESTING=OFF \
32 -DENABLE_MAN=OFF \
29" 33"
30 34
31COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux" 35COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"