summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/selinux/android-tools/android-tools/libfec_mk_change_out_dir.patch
diff options
context:
space:
mode:
authorNisha Parrakat <nishaparrakat@gmail.com>2021-08-08 08:18:35 +0000
committerKhem Raj <raj.khem@gmail.com>2021-08-12 10:08:16 -0700
commit1f1d3812a10e5a20069545d3ec1e2ae034ab05af (patch)
tree8526dd017f373037618726fe20db169d8a561c31 /dynamic-layers/selinux/android-tools/android-tools/libfec_mk_change_out_dir.patch
parenteb92914e31ff872c032155997c42ca8b6e6d82a3 (diff)
downloadmeta-clang-1f1d3812a10e5a20069545d3ec1e2ae034ab05af.tar.gz
upgrade of android-tools to 10.0.0.r36
An older version is present in the meta-oe layer. Took the old recipe and adapted it in the following way: --Deleted all the old patches that were applicable for old version. --Used all the makefiles that come with the new version directly from the source code, just modifying them to install output to a specific folder as below a)added rules_yocto.mk that will mimic the debian/rules b)modified the makefiles of the components to output to a common dir. c) Built boringssl crypto with the option -DOPENSSL_NO_ASM to solve the below errors libcrypto.so.0: undefined reference to `aes_hw_encrypt' libcrypto.so.0: undefined reference to `aes_hw_set_encrypt_key' libcrypto.so.0: undefined reference to `gcm_gmult_v8' libcrypto.so.0: undefined reference to `gcm_init_v8' libcrypto.so.0: undefined reference to `sha256_block_data_order' libcrypto.so.0: undefined reference to `aes_hw_ctr32_encrypt_blocks' libcrypto.so.0: undefined reference to `aes_hw_cbc_encrypt' libcrypto.so.0: undefined reference to `vpaes_decrypt' libcrypto.so.0: undefined reference to `vpaes_encrypt' libcrypto.so.0: undefined reference to `gcm_gmult_neon' libcrypto.so.0: undefined reference to `sha1_block_data_order' libcrypto.so.0: undefined reference to `sha512_block_data_order' libcrypto.so.0: undefined reference to `gcm_init_neon' libcrypto.so.0: undefined reference to `aes_hw_set_decrypt_key' libcrypto.so.0: undefined reference to `vpaes_set_decrypt_key' libcrypto.so.0: undefined reference to `gcm_ghash_neon' libcrypto.so.0: undefined reference to `bn_mul_mont' libcrypto.so.0: undefined reference to `aes_hw_decrypt' libcrypto.so.0: undefined reference to `gcm_ghash_v8' libcrypto.so.0: undefined reference to `vpaes_cbc_encrypt' libcrypto.so.0: undefined reference to `ChaCha20_ctr32' libcrypto.so.0: undefined reference to `vpaes_ctr32_encrypt_blocks' libcrypto.so.0: undefined reference to `vpaes_set_encrypt_key' Attention : https://github.com/grpc/grpc/issues/9440 d) compiled android compatible version of libunwind to be used to build libbacktrace e) REQUIRES meta-selinux for libselinux, thus added it to BBFILES_DYNAMIC of this layer. f) checked compilation and packaging for for x86_64 and aarch64 g) UNTESTED android-tools-adbd.service , couldn't find how to build adbd that is needed by the service with the new version of android-tools. At present the service is still packaged but may not work. h) tested the adb and fastboot on the core-image-minimal by including the android-tools in the image and ran the commands with 'help' Signed-off-by: Nisha Parrakat <Nisha.Parrakat@kpit.com> Signed-off-by: Nisha Parrakat <nishaparrakat@gmail.com>
Diffstat (limited to 'dynamic-layers/selinux/android-tools/android-tools/libfec_mk_change_out_dir.patch')
-rw-r--r--dynamic-layers/selinux/android-tools/android-tools/libfec_mk_change_out_dir.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/dynamic-layers/selinux/android-tools/android-tools/libfec_mk_change_out_dir.patch b/dynamic-layers/selinux/android-tools/android-tools/libfec_mk_change_out_dir.patch
new file mode 100644
index 0000000..0f8184d
--- /dev/null
+++ b/dynamic-layers/selinux/android-tools/android-tools/libfec_mk_change_out_dir.patch
@@ -0,0 +1,35 @@
1--- git/system/extras/debian/libfec.mk 2021-05-17 06:55:51.973044031 +0000
2+++ git/system/extras/debian/libfec.mk 2021-05-17 06:56:41.940185413 +0000
3@@ -1,3 +1,4 @@
4+include ../../rules_yocto.mk
5 NAME = libfec
6
7 # copied from libfec/Android.bp
8@@ -12,20 +13,21 @@
9 CXXFLAGS += -fno-strict-aliasing -std=g++17
10 CPPFLAGS += \
11 -Iext4_utils/include \
12- -Ilibfec/include \
13+ -Ilibfec/include -I $(OUT_DIR)/usr/include \
14 -D_GNU_SOURCE -DFEC_NO_KLOG -D_LARGEFILE64_SOURCE
15 LDFLAGS += -shared -Wl,-soname,$(NAME).so.0 \
16 -Wl,-rpath=/usr/lib/$(DEB_HOST_MULTIARCH)/android \
17- -L/usr/lib/$(DEB_HOST_MULTIARCH)/android \
18+ -L$(OUT_DIR)/usr/lib/$(DEB_HOST_MULTIARCH)/android \
19 -lbase -lsparse -lselinux
20
21 build: $(COBJECTS) $(CXXOBJECTS)
22- mkdir -p $(OUT_DIR)
23- $(CXX) $^ -o $(OUT_DIR)/$(NAME).so.0 $(LDFLAGS)
24- ln -s $(NAME).so.0 $(OUT_DIR)/$(NAME).so
25+ mkdir -p $(OUT_DIR)/usr/lib/$(DEB_HOST_MULTIARCH)/android
26+ $(CXX) $^ -o $(OUT_DIR)/usr/lib/$(DEB_HOST_MULTIARCH)/android/$(NAME).so.0 $(LDFLAGS)
27+ ln -s $(NAME).so.0 $(OUT_DIR)/usr/lib/$(DEB_HOST_MULTIARCH)/android/$(NAME).so
28+ cp -r libfec/include/* $(OUT_DIR)/usr/include/
29
30 clean:
31- $(RM) $(CXXOBJECTS) $(COBJECTS) $(NAME).so*
32+ $(RM) $(CXXOBJECTS) $(COBJECTS) $(OUT_DIR)/usr/lib/$(DEB_HOST_MULTIARCH)/android/$(NAME).so*
33
34 $(COBJECTS): %.o: %.c
35 $(CC) $< -o $@ $(CFLAGS) $(CPPFLAGS)