summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/selinux/android-tools/android-tools/fastboot_compile_remove_gtest.patch
diff options
context:
space:
mode:
authorNisha Parrakat <nishaparrakat@gmail.com>2021-08-08 08:18:35 +0000
committerKhem Raj <raj.khem@gmail.com>2021-08-12 10:08:16 -0700
commit1f1d3812a10e5a20069545d3ec1e2ae034ab05af (patch)
tree8526dd017f373037618726fe20db169d8a561c31 /dynamic-layers/selinux/android-tools/android-tools/fastboot_compile_remove_gtest.patch
parenteb92914e31ff872c032155997c42ca8b6e6d82a3 (diff)
downloadmeta-clang-1f1d3812a10e5a20069545d3ec1e2ae034ab05af.tar.gz
upgrade of android-tools to 10.0.0.r36
An older version is present in the meta-oe layer. Took the old recipe and adapted it in the following way: --Deleted all the old patches that were applicable for old version. --Used all the makefiles that come with the new version directly from the source code, just modifying them to install output to a specific folder as below a)added rules_yocto.mk that will mimic the debian/rules b)modified the makefiles of the components to output to a common dir. c) Built boringssl crypto with the option -DOPENSSL_NO_ASM to solve the below errors libcrypto.so.0: undefined reference to `aes_hw_encrypt' libcrypto.so.0: undefined reference to `aes_hw_set_encrypt_key' libcrypto.so.0: undefined reference to `gcm_gmult_v8' libcrypto.so.0: undefined reference to `gcm_init_v8' libcrypto.so.0: undefined reference to `sha256_block_data_order' libcrypto.so.0: undefined reference to `aes_hw_ctr32_encrypt_blocks' libcrypto.so.0: undefined reference to `aes_hw_cbc_encrypt' libcrypto.so.0: undefined reference to `vpaes_decrypt' libcrypto.so.0: undefined reference to `vpaes_encrypt' libcrypto.so.0: undefined reference to `gcm_gmult_neon' libcrypto.so.0: undefined reference to `sha1_block_data_order' libcrypto.so.0: undefined reference to `sha512_block_data_order' libcrypto.so.0: undefined reference to `gcm_init_neon' libcrypto.so.0: undefined reference to `aes_hw_set_decrypt_key' libcrypto.so.0: undefined reference to `vpaes_set_decrypt_key' libcrypto.so.0: undefined reference to `gcm_ghash_neon' libcrypto.so.0: undefined reference to `bn_mul_mont' libcrypto.so.0: undefined reference to `aes_hw_decrypt' libcrypto.so.0: undefined reference to `gcm_ghash_v8' libcrypto.so.0: undefined reference to `vpaes_cbc_encrypt' libcrypto.so.0: undefined reference to `ChaCha20_ctr32' libcrypto.so.0: undefined reference to `vpaes_ctr32_encrypt_blocks' libcrypto.so.0: undefined reference to `vpaes_set_encrypt_key' Attention : https://github.com/grpc/grpc/issues/9440 d) compiled android compatible version of libunwind to be used to build libbacktrace e) REQUIRES meta-selinux for libselinux, thus added it to BBFILES_DYNAMIC of this layer. f) checked compilation and packaging for for x86_64 and aarch64 g) UNTESTED android-tools-adbd.service , couldn't find how to build adbd that is needed by the service with the new version of android-tools. At present the service is still packaged but may not work. h) tested the adb and fastboot on the core-image-minimal by including the android-tools in the image and ran the commands with 'help' Signed-off-by: Nisha Parrakat <Nisha.Parrakat@kpit.com> Signed-off-by: Nisha Parrakat <nishaparrakat@gmail.com>
Diffstat (limited to 'dynamic-layers/selinux/android-tools/android-tools/fastboot_compile_remove_gtest.patch')
-rw-r--r--dynamic-layers/selinux/android-tools/android-tools/fastboot_compile_remove_gtest.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/dynamic-layers/selinux/android-tools/android-tools/fastboot_compile_remove_gtest.patch b/dynamic-layers/selinux/android-tools/android-tools/fastboot_compile_remove_gtest.patch
new file mode 100644
index 0000000..a04f27f
--- /dev/null
+++ b/dynamic-layers/selinux/android-tools/android-tools/fastboot_compile_remove_gtest.patch
@@ -0,0 +1,51 @@
1socket.h: removing dependency of gtest
2
3Removed the dependency of gtest on the build of fastboot binary.
4Fixes below error
5
6In file included from fastboot/fastboot.cpp:70:
7| In file included from fastboot/tcp.h:36:
8| fastboot/socket.h:43:10: fatal error: 'gtest/gtest_prod.h' file not found
9| #include <gtest/gtest_prod.h>
10| ^~~~~~~~~~~~~~~~~~~~
11| 1 error generated.
12| In file included from fastboot/socket.cpp:29:
13| fastboot/socket.h:43:10: fatal error: 'gtest/gtest_prod.h' file not found
14| #include <gtest/gtest_prod.h>
15| ^~~~~~~~~~~~~~~~~~~~
16| 1 error generated.
17| In file included from fastboot/tcp.cpp:29:
18| In file included from fastboot/tcp.h:36:
19| fastboot/socket.h:43:10: fatal error: 'gtest/gtest_prod.h' file not found
20| #include <gtest/gtest_prod.h>
21| ^~~~~~~~~~~~~~~~~~~~
22| 1 error generated.
23| In file included from fastboot/udp.cpp:31:
24| In file included from fastboot/udp.h:34:
25| fastboot/socket.h:43:10: fatal error: 'gtest/gtest_prod.h' file not found
26| #include <gtest/gtest_prod.h>
27| ^~~~~~~~~~~~~~~~~~~~
28| 1 error generated.
29
30
31Signed-off-by: Nisha Parrakat <Nisha.Parrakat@kpit.com>
32
33--- a/system/core/fastboot/socket.h 2021-04-14 21:14:00.355973915 +0000
34+++ b/system/core/fastboot/socket.h 2021-04-14 21:14:21.879680699 +0000
35@@ -40,7 +40,6 @@
36
37 #include <android-base/macros.h>
38 #include <cutils/sockets.h>
39-#include <gtest/gtest_prod.h>
40
41 // Socket interface to be implemented for each platform.
42 class Socket {
43@@ -119,8 +118,6 @@
44 socket_send_buffers_function_ = &socket_send_buffers;
45
46 private:
47- FRIEND_TEST(SocketTest, TestTcpSendBuffers);
48- FRIEND_TEST(SocketTest, TestUdpSendBuffers);
49
50 DISALLOW_COPY_AND_ASSIGN(Socket);
51 };