summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0004-cmake-Bump-max-LLVM-version-to-18.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-02-16 10:51:09 -0800
committerKhem Raj <raj.khem@gmail.com>2024-03-06 19:18:22 -0800
commit57e06fb428e50e349e2e7af26c537047164ab7de (patch)
treee65ae90af5cf9f2628424cb861e18500b6a7a95c /dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0004-cmake-Bump-max-LLVM-version-to-18.patch
parent22235606aa2d61bbbc0c4bcc684cb665c5657053 (diff)
downloadmeta-clang-57e06fb428e50e349e2e7af26c537047164ab7de.tar.gz
bpftrace: Upgrade to 0.20+ and fix with llvm 18
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0004-cmake-Bump-max-LLVM-version-to-18.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0004-cmake-Bump-max-LLVM-version-to-18.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0004-cmake-Bump-max-LLVM-version-to-18.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0004-cmake-Bump-max-LLVM-version-to-18.patch
new file mode 100644
index 0000000..8a5dbf2
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0004-cmake-Bump-max-LLVM-version-to-18.patch
@@ -0,0 +1,27 @@
1From 16186113346c268a0bb45424ba1c41768b7e94cf Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 16 Feb 2024 10:14:41 -0800
4Subject: [PATCH 4/4] cmake: Bump max LLVM version to 18+
5
6Upstream-Status: Submitted [https://github.com/bpftrace/bpftrace/pull/3009]
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 CMakeLists.txt | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/CMakeLists.txt b/CMakeLists.txt
13index 7983ee17..7d0433de 100644
14--- a/CMakeLists.txt
15+++ b/CMakeLists.txt
16@@ -139,7 +139,7 @@ else()
17 endif()
18
19 set(MIN_LLVM_MAJOR 6)
20-set(MAX_LLVM_MAJOR 17)
21+set(MAX_LLVM_MAJOR 18)
22
23 if((${LLVM_VERSION_MAJOR} VERSION_LESS ${MIN_LLVM_MAJOR}) OR (${LLVM_VERSION_MAJOR} VERSION_GREATER ${MAX_LLVM_MAJOR}))
24 message(SEND_ERROR "Unsupported LLVM version found via ${LLVM_INCLUDE_DIRS}: ${LLVM_VERSION_MAJOR}")
25--
262.43.2
27