summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-cmake-Raise-max-llvm-major-version-to-16.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-02-16 10:51:09 -0800
committerKhem Raj <raj.khem@gmail.com>2024-03-06 19:18:22 -0800
commit57e06fb428e50e349e2e7af26c537047164ab7de (patch)
treee65ae90af5cf9f2628424cb861e18500b6a7a95c /dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-cmake-Raise-max-llvm-major-version-to-16.patch
parent22235606aa2d61bbbc0c4bcc684cb665c5657053 (diff)
downloadmeta-clang-57e06fb428e50e349e2e7af26c537047164ab7de.tar.gz
bpftrace: Upgrade to 0.20+ and fix with llvm 18
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-cmake-Raise-max-llvm-major-version-to-16.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-cmake-Raise-max-llvm-major-version-to-16.patch22
1 files changed, 0 insertions, 22 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-cmake-Raise-max-llvm-major-version-to-16.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-cmake-Raise-max-llvm-major-version-to-16.patch
deleted file mode 100644
index 1806fde..0000000
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-cmake-Raise-max-llvm-major-version-to-16.patch
+++ /dev/null
@@ -1,22 +0,0 @@
1From 85ec062020e4cddf249dd21707752655229e2187 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 10 Mar 2023 00:08:27 -0800
4Subject: [PATCH] cmake: Raise max llvm major version to 16
5
6Upstream-Status: Submitted [https://github.com/iovisor/bpftrace/pull/2528]
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 CMakeLists.txt | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12--- a/CMakeLists.txt
13+++ b/CMakeLists.txt
14@@ -165,7 +165,7 @@ else()
15 endif()
16
17 set(MIN_LLVM_MAJOR 6)
18- set(MAX_LLVM_MAJOR 16)
19+ set(MAX_LLVM_MAJOR 17)
20
21 if((${LLVM_VERSION_MAJOR} VERSION_LESS ${MIN_LLVM_MAJOR}) OR (${LLVM_VERSION_MAJOR} VERSION_GREATER ${MAX_LLVM_MAJOR}))
22 message(SEND_ERROR "Unsupported LLVM version found via ${LLVM_INCLUDE_DIRS}: ${LLVM_VERSION_MAJOR}")