summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-13 09:23:50 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-14 00:52:20 -0700
commit27d44251a6ddc53c3e23917e68693a1effb92573 (patch)
tree9c37f0aef1c63a90259f3ae0dfc832dd84c10f44 /dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
parent224863150c9320b32f344792928af7fbda56d65d (diff)
downloadmeta-clang-27d44251a6ddc53c3e23917e68693a1effb92573.tar.gz
bcc: Upgrade to 0.25.0
Changes are here [1] [1] https://github.com/iovisor/bcc/releases/tag/v0.25.0 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb60
1 files changed, 0 insertions, 60 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
deleted file mode 100644
index 2da1fc4..0000000
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
+++ /dev/null
@@ -1,60 +0,0 @@
1SUMMARY = "BPF Compiler Collection (BCC)"
2HOMEPAGE = "https://github.com/iovisor/bcc"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
5
6inherit cmake python3native manpages
7
8DEPENDS += "bison-native \
9 flex-native \
10 flex \
11 elfutils \
12 ${LUAJIT} \
13 clang \
14 libbpf \
15 "
16
17LUAJIT ?= "luajit"
18LUAJIT:powerpc64le = ""
19LUAJIT:powerpc64 = ""
20LUAJIT:riscv64 = ""
21
22RDEPENDS:${PN} += "bash python3 python3-core python3-setuptools xz"
23
24SRC_URI = "gitsm://github.com/iovisor/bcc;branch=master;protocol=https \
25 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \
26 file://0001-tools-trace.py-Fix-failing-to-exit.patch \
27 file://0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch \
28 file://0001-Vendor-just-enough-extra-headers-to-allow-libbpf-to-.patch \
29 "
30
31SRCREV = "8f40d6f57a8d94e7aee74ce358572d34d31b4ed4"
32
33PV .= "+git${SRCPV}"
34
35S = "${WORKDIR}/git"
36
37PACKAGECONFIG ??= "examples"
38PACKAGECONFIG:remove:libc-musl = "examples"
39
40PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF,"
41PACKAGECONFIG[examples] = "-DENABLE_EXAMPLES=ON,-DENABLE_EXAMPLES=OFF,"
42
43EXTRA_OECMAKE = " \
44 -DCMAKE_USE_LIBBPF_PACKAGE=ON \
45 -DENABLE_LLVM_SHARED=ON \
46 -DENABLE_CLANG_JIT=ON \
47 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \
48 -DPYTHON_CMD=${PYTHON} \
49 -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \
50"
51
52do_install:append() {
53 sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \
54 -i $(find ${D}${datadir}/${PN} -type f)
55}
56
57FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
58FILES:${PN}-doc += "${datadir}/${PN}/man"
59
60COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux"