summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/run-ptest
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-09-07 10:45:25 +0200
committerKhem Raj <raj.khem@gmail.com>2023-09-07 10:39:05 -0700
commit09e448e13853e8bce535967454cf08e62e76c6c0 (patch)
tree5ec6afbfb57c9a2858c5238b26041f5cff359ec7 /dynamic-layers/meta-python/recipes-devtools/bcc/bcc/run-ptest
parentf9795290af3deaa12e5559d308ffac736f51e607 (diff)
downloadmeta-clang-09e448e13853e8bce535967454cf08e62e76c6c0.tar.gz
bcc: move to the right dynamic-layer
* it depends not only on meta-oe, but on meta-python as well and because meta-python depends on meta-oe, we can enable this when ever meta-python is included * fixes: NOTE: Resolving any missing task queue dependencies ERROR: Nothing RPROVIDES 'python3-pyroute2' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) NOTE: Runtime target 'python3-pyroute2' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-pyroute2'] ERROR: Nothing RPROVIDES 'python3-netaddr' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) NOTE: Runtime target 'python3-netaddr' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-netaddr'] ERROR: Nothing RPROVIDES 'bcc-dev' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'bcc-dev' NOTE: Runtime target 'bcc-dev' is unbuildable, removing... Missing or unbuildable dependency chain was: ['bcc-dev'] ERROR: Nothing RPROVIDES 'bcc' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'bcc' NOTE: Runtime target 'bcc' is unbuildable, removing... Missing or unbuildable dependency chain was: ['bcc']
Diffstat (limited to 'dynamic-layers/meta-python/recipes-devtools/bcc/bcc/run-ptest')
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc/run-ptest42
1 files changed, 42 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/run-ptest b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/run-ptest
new file mode 100644
index 0000000..a27f697
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/run-ptest
@@ -0,0 +1,42 @@
1#!/bin/sh
2
3cd tests || exit 1
4
5PASS_CNT=0
6FAIL_CNT=0
7FAILED=""
8
9print_test_result() {
10 if [ $? -eq 0 ]; then
11 echo PASS: "$1"
12 PASS_CNT=$((PASS_CNT + 1))
13 else
14 echo FAIL: "$1"
15 FAIL_CNT=$((FAIL_CNT + 1))
16 FAILED="$FAILED $1;"
17 fi
18}
19
20# Run CC tests, set IFS as test names have spaces
21IFS=$(printf '\n\t')
22for test_name in $(./cc/test_libbcc_no_libbpf --list-test-names-only); do
23 ./cc/test_libbcc_no_libbpf "$test_name" > /dev/null 2>&1
24 print_test_result "cc $test_name"
25done
26unset IFS
27
28# Run python tests, skip namespace tests as they currently don't work
29if cmake -DCMAKE_TESTING_ENABLED=ON -DTEST_WRAPPER="$(pwd)/ptest_wrapper.sh" python > /dev/null 2>&1; then
30 for test_name in $(awk -F '[( ]' '/^add_test/ && !/namespace/ {print $2}' CTestTestfile.cmake); do
31 ctest -Q -R "$test_name"
32 print_test_result "python $test_name"
33 done
34else
35 print_test_result "cmake error, couldn't start python tests"
36fi
37
38echo "#### bcc tests summary ####"
39echo "# TOTAL: $((PASS_CNT + FAIL_CNT))"
40echo "# PASS: $PASS_CNT"
41echo "# FAIL: $FAIL_CNT ($FAILED)"
42echo "###########################"