summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/ptest_wrapper.sh
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-09-07 10:45:25 +0200
committerKhem Raj <raj.khem@gmail.com>2023-09-07 10:39:05 -0700
commit09e448e13853e8bce535967454cf08e62e76c6c0 (patch)
tree5ec6afbfb57c9a2858c5238b26041f5cff359ec7 /dynamic-layers/meta-python/recipes-devtools/bcc/bcc/ptest_wrapper.sh
parentf9795290af3deaa12e5559d308ffac736f51e607 (diff)
downloadmeta-clang-09e448e13853e8bce535967454cf08e62e76c6c0.tar.gz
bcc: move to the right dynamic-layer
* it depends not only on meta-oe, but on meta-python as well and because meta-python depends on meta-oe, we can enable this when ever meta-python is included * fixes: NOTE: Resolving any missing task queue dependencies ERROR: Nothing RPROVIDES 'python3-pyroute2' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) NOTE: Runtime target 'python3-pyroute2' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-pyroute2'] ERROR: Nothing RPROVIDES 'python3-netaddr' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) NOTE: Runtime target 'python3-netaddr' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-netaddr'] ERROR: Nothing RPROVIDES 'bcc-dev' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'bcc-dev' NOTE: Runtime target 'bcc-dev' is unbuildable, removing... Missing or unbuildable dependency chain was: ['bcc-dev'] ERROR: Nothing RPROVIDES 'bcc' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'bcc' NOTE: Runtime target 'bcc' is unbuildable, removing... Missing or unbuildable dependency chain was: ['bcc']
Diffstat (limited to 'dynamic-layers/meta-python/recipes-devtools/bcc/bcc/ptest_wrapper.sh')
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc/ptest_wrapper.sh16
1 files changed, 16 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/ptest_wrapper.sh b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/ptest_wrapper.sh
new file mode 100644
index 0000000..92d0156
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/ptest_wrapper.sh
@@ -0,0 +1,16 @@
1#!/bin/sh
2# Simple OE specific wrapper for bcc python tests
3
4name=$1
5kind=$2
6cmd=$3
7shift 3
8
9case $kind in
10 simple|sudo)
11 $cmd "$@"
12 ;;
13 *)
14 echo "Invalid kind $kind of test $name"
15 exit 1
16esac