summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-09-07 10:45:25 +0200
committerKhem Raj <raj.khem@gmail.com>2023-09-07 10:39:05 -0700
commit09e448e13853e8bce535967454cf08e62e76c6c0 (patch)
tree5ec6afbfb57c9a2858c5238b26041f5cff359ec7 /dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch
parentf9795290af3deaa12e5559d308ffac736f51e607 (diff)
downloadmeta-clang-09e448e13853e8bce535967454cf08e62e76c6c0.tar.gz
bcc: move to the right dynamic-layer
* it depends not only on meta-oe, but on meta-python as well and because meta-python depends on meta-oe, we can enable this when ever meta-python is included * fixes: NOTE: Resolving any missing task queue dependencies ERROR: Nothing RPROVIDES 'python3-pyroute2' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) NOTE: Runtime target 'python3-pyroute2' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-pyroute2'] ERROR: Nothing RPROVIDES 'python3-netaddr' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) NOTE: Runtime target 'python3-netaddr' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-netaddr'] ERROR: Nothing RPROVIDES 'bcc-dev' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'bcc-dev' NOTE: Runtime target 'bcc-dev' is unbuildable, removing... Missing or unbuildable dependency chain was: ['bcc-dev'] ERROR: Nothing RPROVIDES 'bcc' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'bcc' NOTE: Runtime target 'bcc' is unbuildable, removing... Missing or unbuildable dependency chain was: ['bcc']
Diffstat (limited to 'dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch')
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch
new file mode 100644
index 0000000..6ac7219
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch
@@ -0,0 +1,41 @@
1From a9f59fc8605de1bcca0b6c2d8132585f40c3b9bc Mon Sep 17 00:00:00 2001
2From: He Zhe <zhe.he@windriver.com>
3Date: Thu, 13 Aug 2020 11:25:58 +0800
4Subject: [PATCH] tools/trace.py: Fix failing to exit
5
6Class Probe::print_event is used as a callback of a ctypes wrapper. With
7Yocto latest python v3.8.5, the exception raised by exit() is ignored and
8thus trace cannot exit. Use os._exit(0) instead.
9
10$ /usr/share/bcc/tools/trace do_sys_open -M 1
11PID TID COMM FUNC
123740 3740 irqbalance do_sys_open
13Exception ignored on calling ctypes callback function:
14<function PerfEventArray.open_perf_buffer.<locals>.raw_cb at 0x7f7c9efea280>
15Traceback (most recent call last):
16File "/usr/lib64/python3.8/site-packages/bcc/table.py", line 685, in raw_cb_
17callback(cpu, data, size)
18File "/usr/share/bcc/tools/trace", line 630, in print_event
19exit()
20File "/usr/lib64/python3.8/sitebuiltins.py", line 26, in __call_
21raise SystemExit(code)
22SystemExit: None
23
24Upstream-Status: Pending
25
26Signed-off-by: He Zhe <zhe.he@windriver.com>
27---
28 tools/trace.py | 2 +-
29 1 file changed, 1 insertion(+), 1 deletion(-)
30
31--- a/tools/trace.py
32+++ b/tools/trace.py
33@@ -671,7 +671,7 @@ BPF_PERF_OUTPUT(%s);
34 if self.aggregate:
35 self.print_aggregate_events()
36 sys.stdout.flush()
37- exit()
38+ os._exit(0)
39
40 def attach(self, bpf, verbose):
41 if len(self.library) == 0: