summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-09-07 10:45:25 +0200
committerKhem Raj <raj.khem@gmail.com>2023-09-07 10:39:05 -0700
commit09e448e13853e8bce535967454cf08e62e76c6c0 (patch)
tree5ec6afbfb57c9a2858c5238b26041f5cff359ec7 /dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch
parentf9795290af3deaa12e5559d308ffac736f51e607 (diff)
downloadmeta-clang-09e448e13853e8bce535967454cf08e62e76c6c0.tar.gz
bcc: move to the right dynamic-layer
* it depends not only on meta-oe, but on meta-python as well and because meta-python depends on meta-oe, we can enable this when ever meta-python is included * fixes: NOTE: Resolving any missing task queue dependencies ERROR: Nothing RPROVIDES 'python3-pyroute2' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) NOTE: Runtime target 'python3-pyroute2' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-pyroute2'] ERROR: Nothing RPROVIDES 'python3-netaddr' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) NOTE: Runtime target 'python3-netaddr' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-netaddr'] ERROR: Nothing RPROVIDES 'bcc-dev' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'bcc-dev' NOTE: Runtime target 'bcc-dev' is unbuildable, removing... Missing or unbuildable dependency chain was: ['bcc-dev'] ERROR: Nothing RPROVIDES 'bcc' (but /OE/build/oe-core/meta-clang/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.28.0.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'bcc' NOTE: Runtime target 'bcc' is unbuildable, removing... Missing or unbuildable dependency chain was: ['bcc']
Diffstat (limited to 'dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch')
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch
new file mode 100644
index 0000000..3e0a6aa
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch
@@ -0,0 +1,41 @@
1From 4f64ed40e1ffea7ea278627f30a01018e57dcbcf Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Wed, 9 Sep 2020 05:48:19 +0000
4Subject: [PATCH] CMakeLists.txt: override the PY_CMD_ESCAPED
5
6Override the PY_CMD_ESCAPED as the PY_CMD_ESCAPED is constructed by
7the full path of the python3. In some cases, the path is so long and
8result in the PY_CMD_ESCAPED exceeds 255 characters and comes below
9do_configure error:
10 | CMake Error at src/python/CMakeLists.txt:18 (configure_file):
11 | configure_file Problem configuring file
12 |
13 | CMake Error: Could not open file for write in copy operation /buildarea1/test/wr_build/wr1020_20200909_bcc/bcc_long_Kernel/auto-standalone_next/200827/lxbuilds/Intel-Snow-Ridge-NS_platform_up/intel-x86-64-standard-glibc-std/wrlinux/build/tmp-glibc/work/corei7-64-wrs-linux/bcc/0.15.0-r0/build/src/python/bcc--buildarea1-test-wr_build-wr1020_20200909_bcc-bcc_long_Kernel-auto-standalone_next-200827-lxbuilds-Intel-Snow-Ridge-NS_platform_up-intel-x86-64-standard-glibc-std-wrlinux-build-tmp-glibc-work-corei7-64-wrs-linux-bcc-0.15.0-r0-recipe-sysroot-native-usr-bin-python3-native-python3/bcc/version.py.tmp
14
15Upstream-Status: Pending
16
17Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
18---
19 src/python/CMakeLists.txt | 4 ++--
20 1 file changed, 2 insertions(+), 2 deletions(-)
21
22--- a/src/python/CMakeLists.txt
23+++ b/src/python/CMakeLists.txt
24@@ -12,7 +12,7 @@ file(GLOB_RECURSE PYTHON_INCLUDES RELATI
25
26 foreach(PY_CMD ${PYTHON_CMD})
27 string(REPLACE "/" "-" PY_CMD_ESCAPED ${PY_CMD})
28- set(PY_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/bcc-${PY_CMD_ESCAPED})
29+ set(PY_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/bcc-python3)
30
31 foreach(PY_SRC ${PYTHON_SOURCES})
32 configure_file(${PY_SRC} ${PY_DIRECTORY}/${PY_SRC} COPYONLY)
33@@ -31,7 +31,7 @@ foreach(PY_CMD ${PYTHON_CMD})
34 DEPENDS ${PYTHON_SOURCES} ${PYTHON_INCLUDES}
35 COMMENT "Building sdist for ${PY_CMD}"
36 )
37- add_custom_target(bcc_py_${PY_CMD_ESCAPED} ALL DEPENDS ${PIP_INSTALLABLE})
38+ add_custom_target(bcc_py_python3 ALL DEPENDS ${PIP_INSTALLABLE})
39
40 install(
41 CODE "