summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-03-17 19:35:53 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-18 21:56:54 -0700
commit896f641ff0c347aa9874746b226de514c33260f1 (patch)
tree2ac1beeb14cd3607163ce853353def71da1108d1
parentb263a90fe9e8faa1212da000188a77efe33aeaf4 (diff)
downloadmeta-clang-896f641ff0c347aa9874746b226de514c33260f1.tar.gz
openmp: Fix build packaging with multilib suffix
Add missing rdeps on libelf and libffi Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/openmp_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb
index 501ee5a..a4faeaa 100644
--- a/recipes-devtools/clang/openmp_git.bb
+++ b/recipes-devtools/clang/openmp_git.bb
@@ -17,6 +17,8 @@ LIC_FILES_CHKSUM = "file://openmp/LICENSE.txt;md5=d75288d1ce0450b28b8d58a284c09c
17 17
18inherit cmake pkgconfig perlnative 18inherit cmake pkgconfig perlnative
19 19
20EXTRA_OECMAKE += "-DOPENMP_LIBDIR_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
21
20OECMAKE_SOURCEPATH = "${S}/openmp" 22OECMAKE_SOURCEPATH = "${S}/openmp"
21 23
22PACKAGECONFIG ?= "ompt-tools" 24PACKAGECONFIG ?= "ompt-tools"
@@ -33,3 +35,5 @@ INSANE_SKIP_${PN} = "dev-so"
33COMPATIBLE_HOST_riscv64 = "null" 35COMPATIBLE_HOST_riscv64 = "null"
34COMPATIBLE_HOST_riscv32 = "null" 36COMPATIBLE_HOST_riscv32 = "null"
35COMPATIBLE_HOST_mips64 = "null" 37COMPATIBLE_HOST_mips64 = "null"
38
39RDEPENDS_${PN} = "libelf libffi"