summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-04-28 23:10:51 -0700
committerKhem Raj <raj.khem@gmail.com>2020-04-29 08:55:04 -0700
commit30db5271544d052748e554459bd37acaa46614c5 (patch)
treede48ad5a123538de07d81d2ab4c2c7ac56248082
parent0a80aefc523be3ebf2ba4f5e2611434438ee1ff6 (diff)
downloadmeta-clang-30db5271544d052748e554459bd37acaa46614c5.tar.gz
openmp: Do not insttall libgomp.so aliases
libgomp is coming from gcc-runtime and clang does not find it anyway so its better to not synlink it here, so it can avoid clashes with gcc-runtime, anyway clang will use this openmp runtime when using -fopenmp and wont depend on gomp from gcc Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/openmp_git.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb
index d131ac6..e4da94a 100644
--- a/recipes-devtools/clang/openmp_git.bb
+++ b/recipes-devtools/clang/openmp_git.bb
@@ -8,9 +8,6 @@ SECTION = "libs"
8require clang.inc 8require clang.inc
9require common-source.inc 9require common-source.inc
10 10
11RPROVIDES_${PN} += "libgomp"
12RPROVIDES_${PN}-dev += "libgomp-dev"
13
14TOOLCHAIN = "clang" 11TOOLCHAIN = "clang"
15 12
16LIC_FILES_CHKSUM = "file://openmp/LICENSE.txt;md5=d75288d1ce0450b28b8d58a284c09c79" 13LIC_FILES_CHKSUM = "file://openmp/LICENSE.txt;md5=d75288d1ce0450b28b8d58a284c09c79"
@@ -27,6 +24,7 @@ PACKAGECONFIG_remove_mipsarch = "ompt-tools"
27PACKAGECONFIG_remove_powerpc = "ompt-tools" 24PACKAGECONFIG_remove_powerpc = "ompt-tools"
28 25
29PACKAGECONFIG[ompt-tools] = "-DOPENMP_ENABLE_OMPT_TOOLS=ON,-DOPENMP_ENABLE_OMPT_TOOLS=OFF," 26PACKAGECONFIG[ompt-tools] = "-DOPENMP_ENABLE_OMPT_TOOLS=ON,-DOPENMP_ENABLE_OMPT_TOOLS=OFF,"
27PACKAGECONFIG[aliases] = "-DLIBOMP_INSTALL_ALIASES=ON,-DLIBOMP_INSTALL_ALIASES=OFF,"
30 28
31FILES_SOLIBSDEV = "" 29FILES_SOLIBSDEV = ""
32FILES_${PN} += "${libdir}/lib*${SOLIBSDEV}" 30FILES_${PN} += "${libdir}/lib*${SOLIBSDEV}"