summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-31 09:27:28 -0700
committerKhem Raj <raj.khem@gmail.com>2017-07-31 10:35:32 -0700
commit026cb1f7203a16dfd831b7d4901a186c8c446f36 (patch)
tree2ec3584e115f49705ea4620c106b4d78e6a04a0d
parent61579d74eca12998ce988339dc71566a360309a7 (diff)
downloadmeta-clang-026cb1f7203a16dfd831b7d4901a186c8c446f36.tar.gz
compiler-rt: Use final version string in install paths
We append SRCPV to PV which is not what we want for install dir name, it should be final compiler-rt release version e.g. 5.0.0 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 413efd6..50e83b3 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -63,23 +63,25 @@ do_install() {
63 63
64 64
65do_install_append () { 65do_install_append () {
66 install -d ${D}${libdir}/clang/${PV}/lib/linux 66 install -d ${D}${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux
67 if [ -d ${D}${libdir}/linux ]; then 67 if [ -d ${D}${libdir}/linux ]; then
68 for f in `find ${D}${libdir}/linux -maxdepth 1 -type f` 68 for f in `find ${D}${libdir}/linux -maxdepth 1 -type f`
69 do 69 do
70 mv $f ${D}${libdir}/clang/${PV}/lib/linux 70 mv $f ${D}${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux
71 done 71 done
72 rmdir ${D}${libdir}/linux 72 rmdir ${D}${libdir}/linux
73 fi 73 fi
74 for f in `find ${D}${exec_prefix} -maxdepth 1 -name '*.txt' -type f` 74 for f in `find ${D}${exec_prefix} -maxdepth 1 -name '*.txt' -type f`
75 do 75 do
76 mv $f ${D}${libdir}/clang/${PV} 76 mv $f ${D}${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}
77 done 77 done
78} 78}
79 79
80FILES_SOLIBSDEV = "" 80FILES_SOLIBSDEV = ""
81FILES_${PN} += "${libdir}/clang/${PV}/lib/linux/lib*${SOLIBSDEV} ${libdir}/clang/${PV}/*.txt" 81FILES_${PN} += "${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux/lib*${SOLIBSDEV} \
82FILES_${PN}-staticdev += "${libdir}/clang/${PV}/lib/linux/*.a" 82 ${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/*.txt"
83FILES_${PN}-staticdev += "${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux/*.a"
84FILES_${PN}-dev += "${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux/*.syms"
83INSANE_SKIP_${PN} = "dev-so" 85INSANE_SKIP_${PN} = "dev-so"
84 86
85#PROVIDES_append_class-target = "\ 87#PROVIDES_append_class-target = "\
@@ -91,8 +93,6 @@ INSANE_SKIP_${PN} = "dev-so"
91# " 93# "
92# 94#
93 95
94FILES_${PN}-dev += "${libdir}/clang/${PV}/lib/linux/*.syms"
95
96BBCLASSEXTEND = "native nativesdk" 96BBCLASSEXTEND = "native nativesdk"
97 97
98ALLOW_EMPTY_${PN} = "1" 98ALLOW_EMPTY_${PN} = "1"