summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-23 11:33:21 -0700
committerKhem Raj <raj.khem@gmail.com>2022-01-14 10:16:15 -0800
commit088904d40231d9e099c2f5039cd3c2bc47d332d1 (patch)
tree5fa66ed30ac464d058231fda2cfaf319ca1240a6
parentfc5389393adb005b519e488e9e6be4fc5791239c (diff)
downloadmeta-clang-honister.tar.gz
mesa: Drop clang13.patchhonister
It is fixed in 21.2.4 release of mesa already Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@arm.com>
-rw-r--r--recipes-graphics/mesa/mesa/clang13.patch15
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend2
2 files changed, 0 insertions, 17 deletions
diff --git a/recipes-graphics/mesa/mesa/clang13.patch b/recipes-graphics/mesa/mesa/clang13.patch
deleted file mode 100644
index 8387b34..0000000
--- a/recipes-graphics/mesa/mesa/clang13.patch
+++ /dev/null
@@ -1,15 +0,0 @@
1--- a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
2+++ b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
3@@ -351,8 +351,12 @@ lp_build_create_jit_compiler_for_module(
4 */
5 TargetOptions options;
6 #if defined(PIPE_ARCH_X86)
7+#if LLVM_VERSION_MAJOR >= 13
8+ // do nothing
9+#else
10 options.StackAlignmentOverride = 4;
11 #endif
12+#endif
13
14 builder.setEngineKind(EngineKind::JIT)
15 .setErrorStr(&Error)
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 492d25e..74888ba 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,7 +1,5 @@
1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI:append:toolchain-clang = " file://clang13.patch "
4
5LDFLAGS:append:toolchain-clang = " -latomic -lm" 3LDFLAGS:append:toolchain-clang = " -latomic -lm"
6DEPENDS:append:toolchain-clang = " libatomic-ops" 4DEPENDS:append:toolchain-clang = " libatomic-ops"
7 5