summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-01 13:16:18 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-09 07:54:23 -0700
commit342f5d5cd78096bf81fe1ed879c5a8fa5ab21950 (patch)
tree1f20a2cb406a594bc27f9230edb0cf7f256127bf
parent3288f51085698fc376c175ca2f1b6881f514e74d (diff)
downloadmeta-clang-clang-7.0.tar.gz
lld: Do not use libcxx for native and nativesdk variantsclang-7.0
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/lld_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-devtools/clang/lld_git.bb b/recipes-devtools/clang/lld_git.bb
index fac7081..01a8d5e 100644
--- a/recipes-devtools/clang/lld_git.bb
+++ b/recipes-devtools/clang/lld_git.bb
@@ -6,7 +6,8 @@ HOMEPAGE = "http://lld.llvm.org/"
6LICENSE = "MIT | NCSA" 6LICENSE = "MIT | NCSA"
7SECTION = "devel" 7SECTION = "devel"
8 8
9DEPENDS += "clang-native libcxx libxml2 ninja-native" 9DEPENDS += "clang-native libxml2 ninja-native"
10DEPENDS_append_class-target = " libcxx"
10 11
11require clang.inc 12require clang.inc
12require common.inc 13require common.inc
@@ -38,7 +39,7 @@ EXTRA_OECMAKE = "\
38 -G Ninja \ 39 -G Ninja \
39 ${S} \ 40 ${S} \
40" 41"
41CXXFLAGS_append_toolchain-clang = " -stdlib=libc++" 42CXXFLAGS_append_class-target_toolchain-clang = " -stdlib=libc++"
42 43
43do_compile() { 44do_compile() {
44 ninja ${PARALLEL_MAKE} lld 45 ninja ${PARALLEL_MAKE} lld
@@ -47,4 +48,5 @@ do_compile() {
47do_install() { 48do_install() {
48 DESTDIR=${D} ninja ${PARALLEL_MAKE} tools/lld/install 49 DESTDIR=${D} ninja ${PARALLEL_MAKE} tools/lld/install
49} 50}
51
50BBCLASSEXTEND = "native nativesdk" 52BBCLASSEXTEND = "native nativesdk"