summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-06-08 10:45:24 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-08-19 09:49:16 +0000
commit57a02af4d33bd6c2a9270a1995e3b8db97f05292 (patch)
tree5b0e98e799d7c5d794951442dd53c92b7becb5bf
parent31603f60201c3fc90c66ee30a62ccb02cbb18e14 (diff)
downloadmeta-boot2qt-dizzy.tar.gz
cross-localedef-native_2.20.bb: fix for gcc5dizzy
The build of cross-localedef-native is observed to fail under gcc5 hosts with multiple definition errors, e.g.: argp-help.o: In function `argp_fmtstream_write': argp-help.c:(.text+0x1da0): multiple definition of `argp_fmtstream_write' argp-fmtstream.o:argp-fmtstream.c:(.text+0x7a0): first defined here The problem is the change of the default C standard from gnu89 to gnu11 which changes the semantics of 'inline'. The issue is described in the Porting guide at https://gcc.gnu.org/gcc-5/porting_to.html. Adding the '-fgnu89-inline' option fixes the issue. (This fix, including the above explanation, was shamelessly copied from http://git.vahanus.net/?p=csc/ptxdist-kp.git;a=commit;h=2f04a3587bd33c74ccc9be6e115a8b1fde620841.) Task-number: QTBUG-53862 Change-Id: I88b351b618c2aa9838ec5be6108a26369db5d760 Reviewed-by: Heikki Halmet <heikki.halmet@qt.io>
-rw-r--r--recipes/glibc/cross-localedef-native_2.20.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/glibc/cross-localedef-native_2.20.bbappend b/recipes/glibc/cross-localedef-native_2.20.bbappend
new file mode 100644
index 0000000..c673b1e
--- /dev/null
+++ b/recipes/glibc/cross-localedef-native_2.20.bbappend
@@ -0,0 +1,23 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23CFLAGS += "-fgnu89-inline"