summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/files/v2019.07/0001-fpga-arria10-Fix-error-in-fpga-pin-configuration.patch38
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2019.07.bb3
2 files changed, 40 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/files/v2019.07/0001-fpga-arria10-Fix-error-in-fpga-pin-configuration.patch b/recipes-bsp/u-boot/files/v2019.07/0001-fpga-arria10-Fix-error-in-fpga-pin-configuration.patch
new file mode 100644
index 0000000..2ea6e18
--- /dev/null
+++ b/recipes-bsp/u-boot/files/v2019.07/0001-fpga-arria10-Fix-error-in-fpga-pin-configuration.patch
@@ -0,0 +1,38 @@
1From 58b4cc1a3d1e4a989b65892b97af119c25d9a511 Mon Sep 17 00:00:00 2001
2From: Dalon Westergreen <dalon.westergreen@intel.com>
3Date: Tue, 16 Jul 2019 09:12:53 -0700
4Subject: [PATCH] fpga: arria10: Fix error in fpga pin configuration
5
6Pin configuration of the FPGA devicetree block should be done
7after core configuration in the arria10 fpga driver. This fix
8corrects the check of status, and ensures that the fpga pin mux
9is configured on correct configuration of the core fpga image.
10
11Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com>
12---
13 drivers/fpga/socfpga_arria10.c | 9 +++++----
14 1 file changed, 5 insertions(+), 4 deletions(-)
15
16diff --git a/drivers/fpga/socfpga_arria10.c b/drivers/fpga/socfpga_arria10.c
17index 285280e507..5fb9d6a191 100644
18--- a/drivers/fpga/socfpga_arria10.c
19+++ b/drivers/fpga/socfpga_arria10.c
20@@ -936,10 +936,11 @@ int socfpga_load(Altera_desc *desc, const void *rbf_data, size_t rbf_size)
21 fpgamgr_program_write(rbf_data, rbf_size);
22
23 status = fpgamgr_program_finish();
24- if (status) {
25- config_pins(gd->fdt_blob, "fpga");
26- puts("FPGA: Enter user mode.\n");
27- }
28+ if (status)
29+ return status;
30+
31+ config_pins(gd->fdt_blob, "fpga");
32+ puts("FPGA: Enter user mode.\n");
33
34 return status;
35 }
36--
372.21.0
38
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2019.07.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2019.07.bb
index 48a517d..0229a01 100644
--- a/recipes-bsp/u-boot/u-boot-socfpga_v2019.07.bb
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2019.07.bb
@@ -8,7 +8,7 @@ PR = "2"
8 8
9FILESEXTRAPATHS =. "${THISDIR}/files/v2019.07:" 9FILESEXTRAPATHS =. "${THISDIR}/files/v2019.07:"
10 10
11SRCREV = "7e090b466c5ba874d31c1bf22c3a130d516cdc32" 11SRCREV = "e5aee22e4be75e75a854ab64503fc80598bc2004"
12 12
13SRC_URI_append = "\ 13SRC_URI_append = "\
14 file://0001-ARM-socfpga-stratix10-Enable-PSCI-system-reset.patch \ 14 file://0001-ARM-socfpga-stratix10-Enable-PSCI-system-reset.patch \
@@ -24,6 +24,7 @@ SRC_URI_append = "\
24 file://0011-ARM-socfpga-stratix10-Remove-CONFIG_OF_EMBED.patch \ 24 file://0011-ARM-socfpga-stratix10-Remove-CONFIG_OF_EMBED.patch \
25 file://0012-ARM-socfpga-stratix10-Temporarily-revert-to-2GB-DRAM.patch \ 25 file://0012-ARM-socfpga-stratix10-Temporarily-revert-to-2GB-DRAM.patch \
26 file://0001-ARM-socfpga-Stratix10-Disable-CONFIG_PSCI_RESET.patch \ 26 file://0001-ARM-socfpga-Stratix10-Disable-CONFIG_PSCI_RESET.patch \
27 file://0001-fpga-arria10-Fix-error-in-fpga-pin-configuration.patch \
27 " 28 "
28 29
29DEPENDS += "dtc-native bc-native bison-native u-boot-mkimage-native" 30DEPENDS += "dtc-native bc-native bison-native u-boot-mkimage-native"