diff options
-rw-r--r-- | conf/machine/arria10.conf | 13 | ||||
-rwxr-xr-x | recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb | 49 |
2 files changed, 62 insertions, 0 deletions
diff --git a/conf/machine/arria10.conf b/conf/machine/arria10.conf new file mode 100644 index 0000000..676752d --- /dev/null +++ b/conf/machine/arria10.conf | |||
@@ -0,0 +1,13 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: arria5 | ||
3 | #@DESCRIPTION: Machine configuration for the Arria 10 SoC" | ||
4 | |||
5 | require conf/machine/include/socfpga.inc | ||
6 | |||
7 | PREFERRED_VERSION_u-boot-socfpga = "2014.10" | ||
8 | UBOOT_MACHINE = "socfpga_arria10_defconfig" | ||
9 | |||
10 | KMACHINE = "arria10" | ||
11 | |||
12 | KERNEL_DEVICETREE_arria10 ?= "socfpga_arria10_socdk_sdmmc.dtb socfpga_arria10_socdk_qspi.dtb socfpga_arria10_swvp.dtb" | ||
13 | |||
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb b/recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb new file mode 100755 index 0000000..ff9f248 --- /dev/null +++ b/recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | UBOOT_SUFFIX ?= "img" | ||
2 | UBOOT_RAW_BINARY ?= "u-boot-dtb.bin" | ||
3 | UBOOT_DTB ?= "u-boot.dtb" | ||
4 | |||
5 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
6 | |||
7 | FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:" | ||
8 | |||
9 | LICENSE = "GPLv2+" | ||
10 | LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" | ||
11 | |||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
13 | |||
14 | PROVIDES += "u-boot" | ||
15 | PKG_${PN} = "u-boot" | ||
16 | PKG_${PN}-dev = "u-boot-dev" | ||
17 | PKG_${PN}-dbg = "u-boot-dbg" | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | # SPL (Second Program Loader) to be loaded over UART | ||
22 | SPL_UART_BINARY ?= "" | ||
23 | SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}" | ||
24 | SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}" | ||
25 | |||
26 | do_deploy_append () { | ||
27 | install ${S}/${UBOOT_RAW_BINARY} ${DEPLOYDIR}/${UBOOT_RAW_BINARY} | ||
28 | install ${S}/${UBOOT_DTB} ${DEPLOYDIR}/${UBOOT_DTB} | ||
29 | } | ||
30 | |||
31 | # DEPEND on dtc-native for mainline u-boot because the mainline u-boot depends | ||
32 | # on some of the latest syntax constructs for an appended in dtb used for | ||
33 | # items like secure boot/image signing. | ||
34 | DEPENDS += "dtc-native" | ||
35 | |||
36 | DESCRIPTION = "Mainline u-boot bootloader" | ||
37 | |||
38 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919" | ||
39 | |||
40 | PV = "v2014.10" | ||
41 | |||
42 | UBOOT_BRANCH ?= "socfpga_${PV}_arria10_bringup" | ||
43 | UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git" | ||
44 | UBOOT_PROT ?= "https" | ||
45 | |||
46 | SRC_URI = "${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH}" | ||
47 | |||
48 | SRCREV = "${AUTOREV}" | ||
49 | |||