summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb
diff options
context:
space:
mode:
authorDalon Westergreen <dalon.westergreen@intel.com>2017-01-11 10:16:43 -0800
committerKhem Raj <raj.khem@gmail.com>2017-01-11 10:16:43 -0800
commit0c6e036fdfec58b69903a10e886a9dfae8fe4c9f (patch)
treed20289b0fe29ddea1e637248a68e2d0f7c20a89e /recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb
parentab2ee2812670be650d6a722de08dff9bf05131f8 (diff)
downloadmeta-altera-0c6e036fdfec58b69903a10e886a9dfae8fe4c9f.tar.gz
Update uboot and kernel recipes, and fix sdcard class (#44)
* u-boot-socfpga: update PV for all recipes and add common include for mainline uboot versions u-boot-socfpga versioning scheme varied, some prepended with a 'v' others not. u-boot mainline tags versions with vYYYY.MM so we should be consistent. Create a single include for all mainline uboot versions. Signed-off-by: Dalon Westergreen <dwesterg@gmail.com> * u-boot-socfpga: Add support for v2016.11 Signed-off-by: Dalon Westergreen <dwesterg@gmail.com> * Update sdcard image class and add to arria5 / cyclone 5 machine conf * Move arria5/cyclone5 to uboot-socfpga v2016.11 Signed-off-by: Dalon Westergreen <dwesterg@gmail.com> * Update sdcard script Seemed to be an issue with the rootfs partition being slightly smaller then the ROOTFS_SIZE in some cases. Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * uboot: Cleanup v2014.10 recipe v2014.10 is used for Arria10, at this time it does not support GCC6 which is the default for morty * Clean up arria5 and cyclone5 machine definitions Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * linux-socfpga: add 4.7 and 4.7 dev recipes Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * linux-socfpga: update srcrev for 4.6 kernel and remove 4.6 dev Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * linux-socfpga: delete 4.1 dev as 4.1 is no longer maintained * linux-socfpga: update 4.1.22 srcrev to latest release
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb
new file mode 100644
index 0000000..5c82261
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb
@@ -0,0 +1,18 @@
1require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
2PR="r1"
3# This revision corresponds to the SoCEDS 16.1 release
4SRCREV = "ab2181dd766157a74b309d12e0b61c4f3cdc8564"
5
6UBOOT_BRANCH ?= "socfpga_${PV}_arria10_bringup"
7UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git"
8UBOOT_PROT ?= "https"
9
10SRC_URI = "${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH}"
11
12LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
14
15DEPENDS += "dtc-native"
16
17UBOOT_BINARY = "u-boot-dtb.bin"
18