summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-socfpga_2016.05.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2016-05-17 00:48:18 +0200
committerKhem Raj <raj.khem@gmail.com>2016-05-17 15:01:24 -0700
commit82cca7bcd7bdb194f6f399d2b5a9b013e4465615 (patch)
tree0f09b34c1a3d22f86d051eea83040e930e35f162 /recipes-bsp/u-boot/u-boot-socfpga_2016.05.bb
parent5cc2f0ef43afda75a68545036761a2158788a77d (diff)
downloadmeta-altera-82cca7bcd7bdb194f6f399d2b5a9b013e4465615.tar.gz
u-boot: Upgrade to 2016.05
Upgrade the u-boot package to 2016.05 as it contains significant fixes for DDR initialization of the Gen5 socfpga as well as fixes for the problems with QSPI and USB with dcache enabled. Signed-off-by: Marek Vasut <marex@denx.de> Cc: Dalon Westergreen <dwesterg@gmail.com> Cc: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-socfpga_2016.05.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_2016.05.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_2016.05.bb b/recipes-bsp/u-boot/u-boot-socfpga_2016.05.bb
new file mode 100644
index 0000000..fdf0320
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-socfpga_2016.05.bb
@@ -0,0 +1,32 @@
1require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
2
3# This revision is the v2016.05 release
4SRCREV = "aeaec0e682f45b9e0c62c522fafea353931f73ed"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
8
9PV = "2016.05"
10PV_append = "+git${SRCPV}"
11
12DEPENDS += "dtc-native"
13
14do_install_append_10m50 () {
15 if [ "x${UBOOT_CONFIG}" != "x" ]
16 then
17 for config in ${UBOOT_MACHINE}; do
18 install -d ${D}/boot
19 install ${B}/${config}/${UBOOT_DTB_BINARY} ${D}/boot/${UBOOT_DTB_BINARY}
20 install ${B}/${config}/${UBOOT_NODTB_BINARY} ${D}/boot/${UBOOT_NODTB_BINARY}
21 done
22 else
23 install -d ${D}/boot
24 install ${B}/${config}/${UBOOT_DTB_BINARY} ${D}/boot/${UBOOT_DTB_BINARY}
25 install ${B}/${config}/${UBOOT_NODTB_BINARY} ${D}/boot/${UBOOT_NODTB_BINARY}
26 fi
27}
28
29do_deploy_append_10m50 () {
30 install ${D}/boot/${UBOOT_DTB_BINARY} ${DEPLOYDIR}/${UBOOT_DTB_BINARY}
31 install ${D}/boot/${UBOOT_NODTB_BINARY} ${DEPLOYDIR}/${UBOOT_NODTB_BINARY}
32}