summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb
diff options
context:
space:
mode:
authorDalon Westergreen <dwesterg@gmail.com>2019-09-18 14:59:14 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-20 18:39:32 -0700
commit9407e368405e75c6994d75c0903297ec76f2050a (patch)
tree011990588ca32779d31913b57f3a36cb9b92efea /recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb
parenta55ae1a3605d0024f24433a77f1cf2b16461d7ad (diff)
downloadmeta-altera-9407e368405e75c6994d75c0903297ec76f2050a.tar.gz
Remove older u-boot-socfpga implementations
These older versions are no longer supported and in many cases will not even build. Signed-off-by: Dalon Westergreen <dwesterg@gmail.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb b/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb
deleted file mode 100644
index 19ea6c6..0000000
--- a/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1SUMMARY = "U-Boot bootloader environment image creation tool"
2
3HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
4SECTION = "bootloaders"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
8
9PV_append = "+git${SRCPV}"
10
11SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
12SRC_URI += "file://0001-Fix-native-build-by-using-env-variables.patch"
13
14S = "${WORKDIR}/git"
15
16# This revision corresponds to the tag "v2016.11"
17# We use the revision in order to avoid having to fetch it from the
18# repo during parse
19SRCREV = "29e0cfb4f77f7aa369136302cee14a91e22dca71"
20
21EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
22
23do_compile () {
24 oe_runmake sandbox_defconfig
25 oe_runmake cross_tools NO_SDL=1
26}
27
28do_install () {
29 install -d ${D}${bindir}
30 install -m 0755 tools/mkenvimage ${D}${bindir}/uboot-mkenvimage
31 ln -sf uboot-mkenvimage ${D}${bindir}/mkenvimage
32}
33
34BBCLASSEXTEND = "native nativesdk"